Smartsheet Form will not accept responses from all users

I created a Smartsheet Form and have begun receiving responses. One user indicated his response would not submit (See attachment). I verified his responses were not recorded on the Smartsheet. He indicated he was using Google Chrome to submit. I opened the Form on Chrome on my web browser and was able to submit his responses. Any ideas why this would happen?

I use Smartsheet Forms quite frequently and have never had this issue. This is the first Form I have created since the last Smartsheet update where logic was added. Is there a glitch? I'm anxious to have this fixed as I have several forms that are utilized by 1,000s of people. It would be a real mess if I was missing a lot of user data. Thanks.

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭
    edited 05/20/20

    Hi @sccobb

    Ask the user to test it in another browser and also in Incognito mode in Chrome.

    I suspect that it’s a cache issue or maybe a Chrome add-on that is messing with the form somehow.

    If you haven’t already, I would recommend that you reach out to the Smartsheet Support Team.

    Did that work?

    I hope that helps!

    Be safe and have a fantastic week!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it as the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.