Copy and move row workflow disabled by smartsheet

My copy/move row workflows (that previously worked) were disabled yesterday. I now have an error that says "Rows can't be added to the destination sheet because a column has the same name as a system column on the source sheet." Anyone else have this issue? If this is new functionality, then the workflow will only work once since if a column doesn't exist in a destination sheet it is automatically added. Anyone have any info on this error message?

Best Answer

  • Katherine Britt
    Answer ✓

    Looks like a teammate changed the column "type" on the destination sheet to text instead of a system column. This threw everything off. The column type AND the column name have to match when copying/moving rows. I am not sure if this is just for system columns or for all columns...afraid to test it out :)

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi Katherine,

    Has anything changed in the sheets?

    I hope that helps!

    Be safe and have a fantastic weekend!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please help the Community by marking it as the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Nothing has changed in the sheets. I received this notification for several workflows on multiple sheets yesterday.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    @Katherine Britt

    Strange!

    I haven't seen or heard anything, so if you haven’t already, I would recommend that you reach out to the Smartsheet Support Team.

    Let me know how it goes!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Katherine Britt
    Answer ✓

    Looks like a teammate changed the column "type" on the destination sheet to text instead of a system column. This threw everything off. The column type AND the column name have to match when copying/moving rows. I am not sure if this is just for system columns or for all columns...afraid to test it out :)

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    @Katherine Britt

    Glad you found the reason for it not working!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • I received the same error message, but for a different reason. Both the Source and the Destination sheets had differently-named Auto-Number System fields. The copy operation did not match on column names in the Destination sheet, as expected, but instead wrote into the Destination sheet's Auto-Number column. The workflow was able to save without error, but it became disabled and presented the same error message as above.

    It was resolved by removing the column on the destination sheet which had the same name as the auto-number field on the source sheet. Hope this helps someone else!