Automated workflow trigger not working

I have set up a series of simple workflows to change a cell's value based on data in another cell. If the source cell value is changed to "50%" for example, the destination cell will automatically be updated with the number 5. There are several different source cells being used, some of which are "yes/no", and some with a dollar value. All of the workflows I have set up are functioning as they should, so as soon as I save the page they are updated. There is one that does not want to work though. The source cell is a dollar value, and I cant figure out why the same pathway I set up for the other triggers isnt working. All source cells are set up as single option dropdowns, so the cell matches the trigger exactly (ie not $0.00, it will only show $0, which matches the trigger)


Answers

  • Hi.

    I am very new to Smartsheet but I already encountered similar problems with %. Maybe try in workflow to refer to 0.9 instead of 90%.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Kayt Lejeck @Aleksandra B.

    I hope you're well and safe!

    Smartsheet looks at the numbers in a column formatted for percentage as values between 0 and 1. You'd need to use decimal values instead for it to work 

    25% = 0,25 (0.25)

    50% = 0,5 (0.5)

    100% = 1

    Depending on your country/region, you'll need to exchange the comma for a period.

    Did that work/help?

    I hope that helps!

    Have a fantastic week & Happy Holidays!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Kayt Lejeck

    How is your Dollar Value cell being updated, is it a manual entry or a formula? If it's a formula, would you be able to share what that is?

    I would also try testing with just 0, without the $ sign in front.

    Cheers,

    Genevieve

  • @Genevieve P. I set all of the cell value updates as automated workflows. The process is as follows: The source column is set as a $ value, with dropdown options to choose a single value - $0, $10, $20, $30 etc. Once the source cell has a selected value, i have an automated workflow set up to change the cell value in the result cell. i.e. if $30 is selected in the dropdown, the result cell would show 3. This workflow is set up identically for all the various source cells, with the only difference being the content of the dropdown. The workflow works for all other types (percentage, yes/no, etc) but not for the dollar value source. I did test it without the dollar value, and it does work, but I would rather have the dollar value if possible.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Kayt Lejeck

    I'm unable to replicate the behaviour you're experiencing; if I manually enter either $0 or 0 into a column with $ formatting applied, the workflow runs as expected.

    I would suggest deleting the workflow and re-creating it from scratch. If it still doesn't work, please contact Smartsheet Support with full screen captures of the sheet and the workflow, the sheet URL, the workflow ID, and the date/time of the last time you attempted to trigger it.

    Cheers,

    Genevieve

  • Earl Tessmer
    Earl Tessmer ✭✭✭✭✭✭

    Equal to comparisons are next to impossible with floating point numbers. Especially if you are calculating the result. I have seen this on other solutions in the past.