2

I have created a purchase order sheet and form which auto generates a number each time. How do I reference this number to pull it through into the form completion confirmation message and/or email?

Comments

Hi Ed

I did this for a client only this week!  Andree is right, you cannot do it in the form itself, but you can achieve this in an automation workflow. (only requisite is that you are collecting an email address for the person filling in the form, if the email address for the initiator is not currently in your sheet, I would recommend adding it (as a Contact List Column) and popping it on your form).

Within the Form properties, turn OFF the automatic confirmation email.  Instead you can write the confirmation email from the Automation area of the sheet and it can include your auto generated number.

From the Automation Menu, select Create A Workflow

Use the dropdown list on Trigger to select When rows are added

Next to the When heading change Any Field to the name of the autonumber column and set the value to Any Value.

Leave the Run workflow when Triggered as it is.

Select the Alert Someone action type

Select the Send to contacts in a cell and select the contact list column that relates to the initiator of the form.  (see note in first paragraph about this column).

Under Customize message area, type in a subject line for the email; then in the message body, type in the text that you would have put in the confirmation message of the original form.

This last bit is the reason for this workflow! To include data from the form/record in the confirmation email you need to surround its column name reference with placeholders.  In Smartsheet the placeholders are {{ }} The column name must be entered exactly the same way as the Column Name is stored in the sheet (case sensitive)

EG the subject line of the email could be:

Purchase Order {{Purchase Order Number}} has been received.

Where Purchase Order Number is the name of the auto generated number. 

Oh - last point. If you go to the Automation menu again and click Manage Workflows, there is a cog button in the top right corner of the dialog box.  This opens the Automation Permissions dialog box.  The setting must be on Least Restrictive option for this to work.

Hope this helps!

Let me know :)

Kind regards

​Debbie Sawyer Consultant & Training Manager