Hello, we just hooked up the JIRA connector yesterday and I have attained about 90% success with pulling Jira tickets, by epic, into a Smartsheets project plan. 

I'm having two issues that are frustrating me: 

1. Smartsheets is not picking up the epic name from JIRA: field in Smartsheets just says: "Field 'Epic Name' not set" in the field where it should say "epic name".

I am JIRA admin and checked to make sure that "epic name" is the default JIRA field. It is. Nothing custom or weird about it. I have tried changing the epic name from Smartsheets to see if it would change in Jira. Didn't work. 

2. When filling out the workflow step "Optional: Filter JIRA Issues", I do not get the option for a drop down selection. I only get the option to put in a custom JQL query. How do I get the drop down option? 





Hi Karen,

Thank you for working with our Support team on this. To recap, with row grouping, it's expected behavior for the "Field <field name> not set" to appear as the parent row for issues that do not have a group by value set in Jira.

When grouping by Epic Name, the issues synced based on Epic Link (Story, Task, etc.) will have 'Field "Epic Name" not set' since those issues have no Epic Name field value. For the Epic issues synced in the sheet those would fall under 'Field "Epic Link" not set'.

Regarding the filter, if you select more than one project to sync to, you'll need to use JQL in the Connector (under Step 4 here): https://help.smartsheet.com/articles/2476121-jira-workflows