Since the latest update, several users have been complaining that the option of sorting is disabled from column options.

you can select multiple rows and the option is there, but not if you right click on column.


we checked and it works for the same user on the same sheet from windows machine (in IE), but not on his macbook.


any ideas?


Thanks for posting - that is strange! Half my team uses Macs and none of us has experienced this. 


One thing to check - make sure there are no filters applied to the sheet. Ask the user to right click on any column header and select Remove All Filters - then try sorting.


If that does not resolve the issue, would you please send the Support team an email with the following information so they can help you troubleshoot? 


-Email addresses of affected users

-Full screen screenshot of a specific user's view when right clicking on a column header on BOTH Mac and a PC in the same sheet. 

-Email address and sheet name of screenshot example


I will follow up with the Support team to ensure this gets resolved! 


there are no filters. what i suspect now is maybe rows locking?

if we have 2 rows locked in the sheet, might be that anyone that is not admin cannot sort all rows?

i couldn't find direct reference how row locking affects sorting.

Hi Masha, yes locking rows will prevent Editors from sorting the sheet. Editors can select a range of rows that are not locked/not part of a partially locked hierarchy and sort. 

Why can't we sort if there are filters applied?   It sounds like that is the intended operation, but not sure I understand why.   


Do I need to Sort on the desired column prior to applying the filter? 





If you select a group of rows that are displayed after the filter and contiguous (for example rows 101-110 match the filter criteria and are displayed), you can sort that group.

If one row is missing (for example, row 105 does not match the criteria), then the sort option is greyed out.

In this example, you could sort rows 101-104 and 106-110, but not 101-110.