11

Hi,

Can someone else from UK checkout this issue for me.

 

I have "GMT Greenwich" selected in my Smartsheet personal settings, but the Auto-System/Number - Created (Date) is an hour behind actual British SummerTime. Unless of course i'm doing something wrong?

Incidently my computers system clock is correct.

 

Regards

 

Scott 

Comments

Does View History show the correct time? Right click in a cell and select View History. 

Hi John,

Thanks for the reply, view history shows exactly the same "incorrect timestamp", 1 hour behind.

Not being from the UK, I had to look this one up...

 

According to www.timeanddate.com/time/united-kingdom-bst.html 

 

"UK on BST – not GMT – in the Summer. The United Kingdom is not on Greenwich Mean Time (GMT) all year. During Daylight Saving Time (DST) the correct time zone is British Summer Time (BST). The UK observes DST from March to October every year."

 

Right now the UK is not on GMT, they are on GMT + 1. So if your account settings are GMT, then your timestamps will be an hour off. Try adjusting your time settings to a location that uses GMT + 1

This is what i've done now John as a work around. I had a choice between Africa or Europe / Lisbon. (GMT + 1).

 

Maybe it would be easier if Smartsheet used the computers system clock instead of setting it manually? As Smartsheet doesn't allow correctly for UK BST. This makes it a problem when using timestamps. Especially if i forget the change it back again in Oct.

 

Regards

Add my vote to get rid of day light savings time completely (regardless of what it is called in your local timezone and what software you use).

 

Craig

I've requested a simple checkbox feature in the personal settings tab that tells Smartsheet to simply use the computers system clock rather than setting a Time Zone, which is proving inaccurate. 

Hi,

 

just noticed this myself. Most systems can accomodate British Summer Time/Daylight Savings setting etc. It's a bit of an oversight if you can only set GMT (or your other appropriate local time zone). Computer exist so I don't have to remember to change settings twice a year.

 

Any chance of some sort of fix? Local computer time is not really satisfactory with multiple users of a system. So it has to be centrally set for an account.

 

Ta - Roland

Just checked it out more.

 

I changed my personal settings to GMT + 1. All my timestamps were updated to the (currently) correct time. Great. However if I change back to GMT once we move out of BST all my historical stamps (form submit times) will be out an hour. Not so Great.

 

Therefore I presume all the history of changes and form submissions is held against one time zone in the background and adjusted to match with the user time zone set. This makes sense, but does make a siolution to this issue for UK user difficult to impliment...

 

However, here's hoping.

 

Roland

Was this issue ever resolved as I am having the same trouble in that my updated time is showing GMT when we are now in BST. 

Is there going to be a fix?

As another UK user I suffer the same, can we have a fix for this please.

Wonder if Smartsheet are going to listen on this?  Seems incredible that they haven't yet fixed this problem