Link working fine on Android but not in iPhone

Anjanesh Vaidya
Anjanesh Vaidya ✭✭✭✭
edited 07/10/23 in Formulas and Functions

Hello Everyone,  

I have created a column in a Smartsheet that is a link column, fetching information from other columns and auto-populating them by passing the parameter to the form when we click on that link, which overcomes the manual entry process for me. 

I have successfully created it and it is working fine in Android as well, but on the iPhone, it is not working properly, showing only one location (the last location) when more than one location is selected in the link. 

I tried it on the iPad 11 Pro as well, but it was not working in the Smartsheet app but working fine in the Safari browser! 

Can anyone help me understand why it is happening and how to overcome it? 

I’m attaching a screenshot for your reference, taken from the desktop. 

Thanks in advance. 

Regards, 

Anjanesh 

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Anjanesh Vaidya

    I hope you're well and safe!

    Strange!

    If you haven’t already, I recommend submitting a support ticket through the new Smartsheet Support Portal.

    I hope that helps!

    Be safe, and have a fantastic weekend!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up, Awesome, or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Hamza1
    Hamza1 Moderator

    Hi @Anjanesh Vaidya

    Please ensure that you’re on the latest version of your IOS software and mobile app. If the issue persists, as Andrée suggests, I believe that the better route is to open a ticket with the Support team through the customer support portal  so we can help troubleshoot the issue in a private channel and provide assistance. Please provide the following information in your ticket:

    • Make/Model/OS Version of device?
    • App Version(If this is not the most up to date version, please update and try again)? 
    • Has this ever worked before? If so, when?
    • Are you getting an error? What does it say?
    • What steps are you taking before receiving the error/unexpected behavior?
    • Does the issue occur on a cellular data and/or WiFi connection?
    • Is the device managed by a Mobile Device Management (MDM) solution such as AirWatch, Intune, or MobileIron(you may need to confirm with your IT dept.)?

     For more information on the Mobile app see the help center article here.

     Thanks,

    Hamza

  • Anjanesh Vaidya
    Anjanesh Vaidya ✭✭✭✭

    Hi Andrée Starå and Hamza1 Thanks a lot for your recommendations.

    I am working on the issue with Smartsheet support also as you suggested.

    While testing, I have figured out that the link that we have created in the sheet is functioning perfectly when we click from the sheet itself, but when we create a report of it and show that report through the dashboard and then click on the link from the dashboard it is not working !

    I don't know why it is happening in dashboard only.

    It will be great if anyone can let me know about the reason behind it.

    Regards,

    Anjanesh

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!