Hello Guys!

Options
Mohammad Sleem
edited 11/15/23 in API & Developers

I´m using Data Shuttle to offload data from a Sheet to a csv file.

I´m having a constant error which is new : "Workflow Execute: Your workflow maps columns that no longer exist. Please refresh your mapping to remove the deleted columns."

I tried to go and edit the workflow to refresh the mapping but it didnt work. i didnt delete any column in the sheet.

I tried creating a new workflow, but it didnt work either.




Can someone help please?

Answers

  • MichaelTCA
    MichaelTCA ✭✭✭✭✭✭
    Options

    Hello @Mohammad Sleem

    Did you create a copy of the workflow that errors or create an entirely new one from scratch?

    If you refreshed the columns when mapping the workflow and it still received this error, then send support a claim.

    Otherwise you can try:

    Log out of Data Shuttle. Clear your browser cache/cookies. Sign back in and try again.

  • Francisco
    Francisco ✭✭✭✭
    Options

    Running into this same issue - it is frustrating to have to contact support about this...

  • Mohammad Sleem
    Options

    @Francisco hello man i just received an email from customer support and it worked. the problem was an extra space in one of the columns. so just remove it and refresh the columns mapping. and it will work.

  • Mohammad Sleem
    Options

    "The error you are experiencing occurs when columns removed in Smartsheet are not also updated within Data Shuttle. To update columns within Data Shuttle, in the mapping tab there is a refresh button. You'll want to click on that and confirm that the columns removed from Smartsheet are also removed from Data Shuttle.


    Also, please check the source sheet's columns once more to make sure they match the Data Shuttle mappings. I'd recommend checking the column properties of each column to make sure there aren't any extra spaces at the end of the columns or misspelled words, which could be a possible cause of the issue. To edit the column names, right click on the column header > Edit Column Properties."

  • Mohammad Sleem
    Options

    @Francisco hello man i just received an email from customer support and it worked. the problem was an extra space in one of the columns. so just remove it and refresh the columns mapping. and it will work.



  • Francisco
    Francisco ✭✭✭✭
    Options

    @Mohammad Sleem - Wow! This worked! Thank you, Mohammad!

    The error was caused by a space at the end of a column in the source sheet. What a silly issue that breaks Data Shuttle...