Update Rows via API started to fail recently

edited 02/27/24 in API & Developers

I have created an automation in Alteryx to Insert/Update/Delete row data via the API. Everything worked perfectly until sometime this month. The Insert and Delete parts work fine, but when I try to do the Update, I get an "Unable to parse request" message all of a sudden.

An example payload I'm sending looks like this:

{"id": 2398070350210948, "cells": [ {"columnId": 3178991682119556, "value": true},{"columnId": 7682591309490052, "value": "2021-12-30"},{"columnId": 767693962930052, "value": "A", "strict": false},{"columnId": 5834243543721860, "value": "AAA"},{"columnId": 3582443730036612, "value": 666} ] }

I'm also encoding the payload into a blob before finally sending it. Here's the configuration:

Again, everything was fully tested and was running without a hitch up until recently. Something from your end must have changed. I reviewed the API documentation again, but I can't seem to find what was the thing that you changed.


  • Leibel S
    Leibel S ✭✭✭✭✭✭


    Why are you encoding the data?

    Unable to parse means that the way the data is not in a valid Json format. Maybe there is an issue with quotation marks, values missing etc.

  • @Leibel S

    The Download tool in Alteryx wouldn't work with the PUT action without the encoding done.

    While I still do not know what really happened, I found a workaround for the issue. Instead of using the PUT action in the Download tool, I selected "Custom" and typed "PUT". Somehow it worked then, and the encoding step was not necessary as well then. Probably this is an issue with how the default PUT action is performed in Alteryx.