Why does this column formula doesn't work?

Options

I have this formula I'm trying to convert to a column formula, but I get an error message. Any ideas why? Thanks!

=VLOOKUP(Site@row; {Gestionnaires EPI Plage 1}; 2; false)

Answers

  • David Tutwiler
    David Tutwiler Overachievers Alumni
    Options

    Yes, you need to use commas not semi-colons between your parameters in the formula. Otherwise you'll get UNPARSEABLE

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Stéphane Charbonneau

    Our Support team has confirmed that the error message you're seeing when trying to convert a formula into a Column Formula is an issue that occurs if your regional settings require the use of semi-colons instead of commas. The Engineering team is aware of the issue and will be investigating it.

    In the meantime, you can either continue to use formulas as you were before (using drag-fill down a column), or if you wanted to set a formula as a Column Formula, you can follow these steps:

    • Set language preferences to English (United States). 
    • Navigate to the account bubble in top right corner of the Smartsheet home page > Personal Settings > Settings > Regional Preferences dropdown
    • Sign out of Smartsheet account and back in
    • Create cell formula
    • Right click formula and convert to column formula
    • Change language preferences back to primary language
    • Sign out of Smartsheet account and back in

    Thanks!

    Genevieve

  • Stéphane Charbonneau
    Options

    Hi Genevieve,


    does that mean that I would have to change ALL my formulas in ALL my sheets!?! IE using commas instead of semi-colons?

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Stéphane Charbonneau,

    This issue only applies to the new function that was released today, for formulas that you want set up to be a Column Formula (see the Help Center article on this type of formula, here).

    You can keep using your formulas exactly as you were before without needing to convert them to commas, if you don't want to adjust anything or have Column Formulas set up yet.

  • Julie Barbeau
    Julie Barbeau ✭✭✭✭
    Options

    @Genevieve P I have the same problems (we use french version with semi-colons). Can you confirm when it will be fixed? It's a feature we MUST have :) Thanks

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Julie Barbeau,

    We don't have an ETA for when formulas with semi-colons will be able to use the new Column Formula feature; the Help Center article will be updated when we have more information! (See the "Important" notice at the top, here, with a solution for the time being.)

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Stéphane Charbonneau and @Julie Barbeau

    Just a quick note to let you know that our Product team has pushed an update to Smartsheet columns and formulas that use ; instead of , are able to be implemented as Column Formulas!

    Cheers,

    Genevieve

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!