I am trying to get access token using Oauth

CHANDRU DCHANDRU D
edited 10/28/20 in API & Developers
10/24/20 Edited 10/28/20
Answered - Pending Review

I am trying to integrate Power Automate (Workflow service) with SmartSheet using OAuth 2.0

I have got the code successfully and when I finally try to get the token, it throws the message - 'You are not authorized to perform this action.' with error code 1004

I tried in Postman with same result.


Any help would be much appreciated

Answers

  • Hi @CHANDRU D

    That type of error usually indicates some sort of issue with the permissions specific to your Smartsheet account or plan. Only licensed Smartsheet users on Business and Enterprise plans have access to the API by generating Access Tokens (see the Developers portal for more information.) Is it possible that the account you're generating an access token for is not licensed?

    If this isn't the issue, I would suggest contacting Support to see if they can help you find the cause one-on-one.

    Cheers,

    Genevieve

Sign In or Register to comment.