Column formula not applied to all rows in smartsheet

Options

I have 768 rows in smartsheet, why is column formula getting applied to only 744

Answers

  • Lucas Rayala
    Lucas Rayala ✭✭✭✭✭✭
    Options

    You may have accidentally selected "Convert to Cell Formula" at some point. Right click the cell -- if you have the option to "Make Column Formula", then that's your issue. Redo the column formula. Otherwise, you may have some exclusionary terms in your formula that shut it down for certain cells.

  • Harpreet
    Options

    Thank you Lucas. It's definitely a column formula . All I'm doing is INDEX MATCH. For all the columns, the formula stops at row number 744 and doesn't go all the way down to row number 768.

  • Sandra Guzman
    Sandra Guzman ✭✭✭✭✭✭
    edited 03/10/22
    Options

    Hi @Harpreet,


    It definitely seems odd that the formula is not applied to the last rows. In Smartsheet, the last rows are generally blank as the system adds extra rows to the bottom of the sheet. It's the current system behavior. You can read comments from a previous post that addresses this issue.


    If the rows you are referring to have data included and these are not blank rows - this could be happening for a variety of different reasons. I would first go through some of the troubleshooting steps below.

    1) Confirm that the column formula displays the fx in the column header.

    2) Reapply the formula by converting back to cell formula and then convert back to column formula. You can do this by right clicking in the cell to display the menu of options and then select "Convert to Cell Formula." After you have done that go back and right click and then select "Convert to Column Formula." Save changes, refresh your screen and go back and check. If that is not working then move on to 3 below.

    3) Check your formula for the index match and validate that the match details are present. If the match details are present and should yield a result, then move to 4 below.

    4) You might have something that existing in the previous cells that are corrupt or causing this behavior. I would go back to step 2 and covert back to column formula. Go to the cells that are blank and clear the contents from that cell. Resave the sheet and then convert back to the column formula.


    Try these steps and hopefully something here helps you. If none of the above work... I would suggest sharing your sheet here so that we can look at it a little more closely.


    All the best,

    Sandra

  • Lucas Rayala
    Lucas Rayala ✭✭✭✭✭✭
    Options

    Can you screenshot the formula and what you see when you right click the cell?

  • Harpreet
    Options

    Thank you for your responses. It was just a UI issue. For some of the blank rows, it was not showing blue inbound link . However when I input data in the rows, formula works fine.