Workapp not loading Dashboard

Options
SBell
SBell ✭✭
edited 06/14/22 in Add Ons and Integrations

Hi all

Have created a workapp with a dashboard, a number of sheets and reports. Created roles and assigned pages to the roles with their permissions. All Smartsheet items that support the dashboard have been added to the workapp.

When in design/draft mode I see the content including the Dashboard. When attempting to preview the workapp is just sits spinning (loading) and an error icon is on the Dashboard - "There was an issue loading the page."

There was a report on the dashboard with a Gantt, I removed the Gantt knowing workapp doesn't like Gantt reports, however it did not change anything.

Other tidbits for the dashboard - 81 dashboard widgets, 5 underlying sheets as source.

Has anyone run into this. I'm sure it's going to be something silly, however I just cannot locate the root issue.

Thanks in advance

Shawn

PS I've also created a test app and used a workapp template and have encountered the same issue.

Best Answer

  • SBell
    SBell ✭✭
    Answer ✓
    Options

    UPDATE: Decided to remove all users from all roles and Publish the Workapp with just myself as a user in each of the roles. This correctly showed the content and resolved the issue with doing a Preview while editing the Workapp.

    Appears that you need to at least Publish once.

Answers

  • SBell
    SBell ✭✭
    Answer ✓
    Options

    UPDATE: Decided to remove all users from all roles and Publish the Workapp with just myself as a user in each of the roles. This correctly showed the content and resolved the issue with doing a Preview while editing the Workapp.

    Appears that you need to at least Publish once.