Why my workflow won't send to two contacts

Options

Hi there,

I have set up an automation for alerting a manager when a task date is moved out or a task is completed.

At times I need to add more than one contact.

When I test with two contacts, only one of them receives the alert.


Both contacts are in the "Mentor" field

What am I doing wrong?

Answers

  • Dale Murphy
    Dale Murphy ✭✭✭✭✭✭
    Options

    @Tamsyn Did you check your permission settings as prompted? If your alternate address is considered external, the workflow will not send to it without expanded permissions.

    Or, if it is the same address the tool only sends the message once.

    dm

  • Tamsyn
    Tamsyn ✭✭
    Options

    @Dale Murphy thank you for responding to me.

    My primary email is set as Admin (this is the one that doesn't receive the alert).

    My test email is set to editor - can share.

    For the automation I have set to Restricted - of which both have logged in before.


  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭
    Options

    Hi @Tamsyn

    I hope you're well and safe!

    To add to Dale's excellent advice/answer.

    Ensure that you've checked the Sheet Change Notification Settings box to Include my changes in sheet notifications in your Personal Settings (circle/profile in the lower-left corner).

    Did that work/help?

    I hope that helps!

    Be safe, and have a fantastic week!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up, Awesome, or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:andree@workbold.com | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Tamsyn
    Tamsyn ✭✭
    Options

    Thanks Andree,

    I found the solution. I had used an index match formula to populate the right recipients but in the column where it pulled this information into I had not allowed for multiple contacts.

    It is now working as expected!

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭
    Options

    @Tamsyn

    Excellent!

    Glad you got it working!

    Happy to help!

    Please support the Community by marking your post with the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:andree@workbold.com | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!