Date column is not recognized as a Date in Reports

Options
Mike Khan
Mike Khan ✭✭
edited 05/23/23 in Formulas and Functions

 After adding two columns to a source sheet, my reports built over that file with filters on date columns stopped to recognize the date columns as date. The column in the original file still interprets the date column as date, but not on the reports built over it. 

  1. Log off / Log in
  2. Remove / add the columns again.
  3. Recreate the report.
  4. Tried every step above after deleting the columns I've created.

Nothing seems to work.


Curiously, the calendar view works for my reports when filters are off. But they can not be filtered also.

Anyone can help me ? :*

Tags:

Answers

  • Debbie Sawyer
    Debbie Sawyer ✭✭✭✭✭✭
    Options

    @Mike Khan

    What other options do you have on your filter list? The "is not a date" is a filter condition that applies to Date Columns. Click the dropdown arrow to the right of "is not a date" and more filter conditions will show up...

    The report looks fine to me. It might just be the filter condition showing is mis-leading you perhaps?

    If this doesn't help, I am more than happy to connect via Zoom and see the issue in person?

    Kind regards

    Debbie

  • Mike Khan
    Options

    Hey Debbie - Thanks for replying.

    I've tested the error with other people as well to avoid being misled. But basically the report started to work again on the following day (nothing was changed). As we are facing some issues with performance , we considered this bug to also be associated with that .

    Thanks again,

    Mike

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!