Configured Automation Alerts Not Working

Althought the automation shows last run accordingly. The alerts do not reach the recepients. I tested multiple times even with a trigger checkbox but the email is not being received.

I've tested 4 sheets.

What is bothersome is that since the past 3 days we have set up daily alert emails to over 100 clients in different sheets where they should be responding. As I said, the last ran shows the automation ran but for 2 weeks I have not received a single response.

The expectation for response is 100% as the email informs them of the 75% of discount on quoted fees. These clients have already activated debit order for the original fees. All they have to do is to reply and authorize us to change the debit order term for the new fees.

Also from 16 October to 31 October we sent Birthday Discounts (75%) as above to the same clients. Zero response.

On the other hand, alerts for when rows are added, some function and some not.

Trust me I tried every feasible test, using different email address, filling new forms for alert when rows are added.

On another matter, not related but equally bothersome, last week I noticed all forms where deactivated - and I mean all! I never deactivated forms. I had to activate every form.


Please investigate both issues and let me know if you received similar queries or what might be wrong with my sheets?

Thank You.

Davinci

Answers

  • Ella
    Ella ✭✭✭✭

    @Davinci make sure notifications permissions are set to Unrestricted. Also unless the clients emails are in your approved domains, the notifications won't go out.

  • Davinci
    Davinci ✭✭
    edited 11/03/23

    Thank you @Ella

    All my sheets are older than 1 year and all alerts have been running properly with notification permission set to Unrestricted. The client emails are supplied by clients through the registration forms and the email column is set as Contact List.

    According to your response it seems that nobody else encoutered this issue? Also about the forms being deactivated?

    I want to add that for this entire week, I'm not receiving any response to any automated emails. This is unusual as clients need to respond with crucial documents for the service processes to proceed.

    Davinci