Smartsheet Form stopped populating all fields from the back end to front end

Options

Hello,

I have an SS form that was working fine until last week. Not all questions appear on the front end (submitter view). However, all fields are on the back end of the form. Can someone tell me what could happen and what should the resolution be? I cant figure out why some questions are not visible on the submitter view.

Thank you!

Answers

  • Monique_Odom_Comcast
    Monique_Odom_Comcast ✭✭✭✭✭✭
    Options

    Hello @Magdalini Finelli,

    Some of the forms may be marked as Hidden (which means submitters will not see that question) or have logic to only show if a certain response is selected for another question. If you open the form setup, you will be able to see what questions are selected as Hidden or have logic tied to them.

    If neither of these are the case, can you send a screenshot of the questions causing issues (making sure to remove any confidential information first)?

    If my comment helped you, please help others by marking it as an accepted answer and consider helping me by clicking the 💡Insightful or ❤️Awesome buttons below!

    Monique Odom

    Business Process Excellence Manager

    Smartsheet Leader & Community Champion

    Pronouns: She/Her (What’s this?)

    “Take chances, make mistakes, get messy!” – Ms. Frizzle

  • Magdalini Finelli
    Options

    Hi @Monique_Odom_Comcast

    I appreciate your reply. The questions aren't hidden and they were visible as of last week. Please see below one of the questions having the issue.


  • Monique_Odom_Comcast
    Monique_Odom_Comcast ✭✭✭✭✭✭
    Options

    @Magdalini Finelli,

    Thank you for the screenshot! It looks like there is logic tied to this question, meaning that it will only show up when the triggering question is answered with certain criteria. If you hover over the little icon to the right of the Logic box, it will tell you what question has the criteria required.

    Can you test out the form to see if a submitter can see this question if they are appropriately selecting the required criteria in the triggering question?

    If my comment helped you, please help others by marking it as an accepted answer and consider helping me by clicking the 💡Insightful or ❤️Awesome buttons below!

    Monique Odom

    Business Process Excellence Manager

    Smartsheet Leader & Community Champion

    Pronouns: She/Her (What’s this?)

    “Take chances, make mistakes, get messy!” – Ms. Frizzle

  • Magdalini Finelli
    Options

    Yes, there is a logic. However, the submitter cannot see the question on the screenshot though. On the submitter view, the form stops before the question on the screenshot.

  • Magdalini Finelli
    Options

    Good morning @Monique_Odom_Comcast

    I figured it out. There was a second logic tag on the question tied to another main question which shouldnt be tied. It is very odd how it happened but I resolve it. :)


    Thank you for your help! Have a wonderful week!