Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Issue with comments in Community

11/21/17

Hi Guys,

This is an issue not with SmartSheet but with this forum.

I have tried Chrome, Opera, Firefox and Edge on Windows and Chrome and Firefox on Linux and get exactly the same behaviour:

The issue affects just content in the Comments section of posts in the Community. 

When I am not logged in to the Community and open one of my posts I can select any text in the comments section and click on links in the comments section. Notice in the pic below that the mouse pointer changes to a hand over the hyperlink indicating it is clickable and indeed when I click the hyperlink is opened.

Mouse icon changed to hand hovering over hyperlink

However when I log in to the community I can no longer select any text in the comments section. I can select text in the original post, above the comments section (on the same page). But I can't click on any of the links in the comments section either, so I can't click on the Edit hyperlink to edit the post. See in the image below the mouse icon remains as an arrow when I hover over the link and on clicking no action is performed. This the case for all the links in the comments section - I can't click on the Reply link either.

mouse icon not changing to hand icon when hovering over link

As I mentioned this seems to happen with all browsers. In Chrome I have tried an incognito tab, clearing cookies and cache and rebooting my Windows machine with no change in behaviour. 

Comments

  • Chris McKayChris McKay ✭✭✭✭✭

    I'll second this.

    Windows 10 PC using Microsoft Edge 40.15063.674.0 and Chrome 62.0.3202.94 (64-bit) and I get exactly the same behaviour.

    I've taken to logging out of the community site, finding the link I need, copying it, logging back in and pasting the URL into the address bar.

    Strangely the only links that work (on the left side of the page) are those associated with the original comment in each thread, the link to the Mollom privacy policy, any thread tags and the buttons in the file attachment area.

    Any links in the Comments section are not accessible when logged in.

  • Mike WildayMike Wilday ✭✭✭✭✭

    For those of you using Chrome, rather than logging out, you should use an incgonito window to grab the links. It will be much faster. Just copy the url of the page you're on, Cntrl+Shift+N to get an incognito window and then paste the url there. That should save a few seconds while they work on a fix. 

  • Chris McKayChris McKay ✭✭✭✭✭

    Thanks Mike,

    I should have been clearer with my instructions. I do use Chrome incognito or use Edge as a secondary because I never log into Smartsheet with it.

  • Thanks for the tip Mike. It'll be good when it's fixed because even in an incognito window we can't edit a comment post, the Edit link doesn't work.

  • Mike WildayMike Wilday ✭✭✭✭✭

    Yes, I was suggesting using icognito to quickly grab or navigate to the link, without having to logout. It's definitely an Operating System issue, cause I am on a Mac and haven't seen this issue. 

  • I'm typing this in Opera in Linux. I see the same results in Firefox and Chrome in Linux as well as Chrome, Firefox, Opera and Edge in Windows. In none of these browsers in either Linux or Windows can I access the Edit | Reply | Report as Spam links nor can I click on any hyperlink or select any text in the comments section. So, if it is an OS issue it applies equally to Linux and Windows. 

  • Chris McKayChris McKay ✭✭✭✭✭

    Oh the irony of having to open an incognito window just so I can copy the link you posted frown

  • Mike WildayMike Wilday ✭✭✭✭✭

    haha. I totally hear you. 

  • Hi all,

    Please do reach out to our Support team if you're experiencing this issue. It's proving to be a tricky one for our team to isolate ... so if you're able to help us with environment information or repro steps in a support ticket that would be super helpful.

    http://www.smartsheet.com/gethelp

    Thanks!

    Gwyneth

  • edited 12/20/17

    Well there ya go! I logged in today and I can select text and edit old posts (hyperlink is now clickable). What's changed? I haven't a clue. Will the issue return? I bet it does sometime in the future. But for now alles gut! smiley

  • Good to hear! Are you aware of any recent changes to your environment (OS) or browser?

    Thanks for persisting (and of course, for your participation in Community).

    -Gwyneth

  • No, I wish I was aware of what has changed but I can't pin anything on it. No doubt Chrome has updated and there have been Windows updates. Actually thinking of it, I'll log in to my Linux machine and try it there too.

  • Chris McKayChris McKay ✭✭✭✭✭

    Yep, I can confirm it's working for me too. Thank you for following up Support Team!

This discussion has been closed.