Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Row indenting is not working

Aaron Bowman
edited 12/09/19 in Archived 2015 Posts

I am having problems indenting rows on my sheets.


I have parent rows that I would like to have child rows beneath.

However, when I click the indent on the child rows, the cursor on the parent row is missing.


My cells have data, and there are now hidden blank rows.

Also, when I go to delete a child row, it gives me a warning that I will be deleting all the child rows if I continue, so it look like it worked.......I am just not able to hide the child rows under the parent rows.


I am confused. I got it to work on another sheet, just won't seem to work on this one.


Thank you in advance for help! -Aaron


  • Hey Aaron, based on the message you get when you delete a particular row, it sounds like you do have parent/child rows set up in the sheet but they just aren't displaying as such.


    The indentation, and expand/collapse icons, would only appear in the Primary Column of your sheet. Any chance this column is hidden, or scrolled out of view? Try right-clicking any column header to "Unhide All Columns" to see if this helps.

  • I am am not understanding why on some sheet I can use the indent outdent and on others I can't. Not matter what line I click on it a document those features wont show up.


  • I am experiencing this problem, too. Some lines indent normally, with the indented line becoming a child of the line above it. The parent line then gets a + sign in front of it, as normal.

    However, for no reason I can determine, some "parent" lines do NOT get a + sign in front of them.

    I've tried deleting both the parent line (and recreating) and the child line (and recreating), but nothing helps.

    Anyone know why this is happening and how to correct?

    See attached screenshot.


  • I know this is an old thread, but I'm having the same issues Zuk Zukowski is having above and am hoping somebody has an answer. Thanks!

  • Victor, in my case, it was because I had some rows hidden. If you look in my screenshot, you can see under the red X that the row numbers jump from 196 to 341.

    I had forgotten that a filter was applied. Once I cleared the filter (unhiding all rows), the indentation was working properly.

    I'm glad you posted this, because I forgot to update my post back when I solved the problem. Bad Zuk! :^)

This discussion has been closed.