Data Uploader Errors

early818
early818 ✭✭
edited 12/09/19 in Smartsheet Basics

Hello,

 

I am attempting to upload a csv into a smartsheet plan.  I am getting about 60% of my rows imported successfully while about 40% are continuously skipped.  Some of these rows contain odd characters in various cells that are not traditional letters/numbers. I am unable to figure out why.

For context I am reviewing the Log Messages. Almost all of my errors have a similar associated message. "Error reading Excel File. Expected 75 columns, but row 249 has 74".  Can anyone help me interpret this?  I am attaching and uploading a csv so I am unsure why its reading an excel file.  I also don't know how to investigate the columns piece of the error message.

Any insight would be very helpful

 

 

Comments

  • L_123
    L_123 ✭✭✭✭✭✭

    Check the last comma in the file. if there isn't a comma at the very end try adding one and saving it, and vice versa.

    If that doesn't work - 

    Try opening the file in excel and saving it as xls or another excel filetype then importing it.

     

     

  • Matt@spec
    Matt@spec ✭✭
    edited 01/03/19

    Happy New Year!! Could you tell me if a fix was ever presented for this? I am having the same issue. I did check and a comma is set after the last column. If i convert to .xls, it works fine. Unfortunately, this is not a fix as we can only currently push out .csv from our system. I have attached a screenshot of the current log. Any help would be greatly appreciated.

    Screen Shot 2019-03-1 at 10-28-43.png

  • _Stephanie_
    _Stephanie_ ✭✭✭

    I'm having the same problem. It's skipping 8 out of 37 rows, saying it expected 73 columns but those rows only have 72. I can't see any difference between those 8 rows and the others. All have commas a the end. I saved as .xlsx file and tried again. This time is said it was successful instead of giving me an error message, but then said all the rows had been skipped. I also tried saving as .xls file and it just gave me an error in the settings, saying it couldn't parse the content and no input columns were found.

    Has anyone come up with a solution to this? Thanks!

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi Stephanie,

    If you haven’t already, I would recommend that you reach out to the Smartsheet Support Team. Smartsheet Support Team

    Hope that helps!

    Have a fantastic week!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    work-bold

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.