#NO MATCH then it's fine, then it's #NO MATCH again



I have a VLOOKUP formula in my sheet, and it was working for days... then today I got a bunch of "#NO MATCH".

I repasted the formulas and refreshed all sheets and re-saved etc... This fixed some of them but I still have many "#NO MATCH".

Then, I copied the text of what was being searched... into the original reference sheet, to ensure the text was identical, but this didn't fix it.

Please help! I'm creating this for a client and I'm on a time crunch.

Thank you!


  • Nasir@EBC
    Nasir@EBC ✭✭✭


    It looks like that the the VLOOKUP formula that you are using, is not having a static reference to the lookup table, using the $ signs.

    Because when we copy a VLOOKUP function on to other rows, the table reference must remain static.

    So please check and ensure that the lookup table is having a static reference.

    Hope this helps


    Nasir (Zealvert)

  • Paru Radia

    Thank you.

    I tried to re-establish what the selected range was, but it didn't work.

    I then deleted all of the formulas and manually entered the formula again... and it worked, so I dragged it down.... and it worked!

    I did this before seeing your response. if it becomes a problem again, I'll try what you suggested. Thanks

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!