Calculation in column is not auto-populating

I have a spreadsheet with a calculated column (If statement based on previous column). I regularly paste in new rows, but the calculated columns do not always auto-populate. When I hover over the calculated cell, the calculations are present, but they are not calculating unless I select the cell. Is there a reason for this or a way to fix this?



  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    Can you provide screenshot(s) with sensitive/confidential data removed, locked, or replaced with "dummy data" as needed showing what is happening?

  • The "Order" column is what is being populated below. Once a week we upload data manually (sometimes 80+ rows at a time). When the data is added, the "Order" column stays blank.

    What we are trying to do is sort our data in a report using "Operating Area", but we don't want to sort alphabetically, there is a specific order that our organization prefers to list the data. The "Order" column assigns a number to each "Operating Area" option and then we sort by "Order" alphabetically in the report.

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    Hmm... It should be populating as long as the two rows above the new data are of the same format, have the same hierarchy level, and contain the formula.

    I haven't pasted that many rows at once before, but maybe there is a limit to how far the autofill will work when pasting large amounts of data at once. I will do some testing at some point today and see if I can replicate your results and possibly come up with a solution/answer for you.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!