Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

BUG: Auto-fill behavior has changed

Options
J. Craig Williams
J. Craig Williams ✭✭✭✭✭✭
edited 12/09/19 in Archived 2017 Posts

This used to work, I've used it in my workflow, documented it and passed it on to the customer.

Now it doesn't.

 

I have a sheet, 22 columns wide.

At the top of the sheet are several rows (in this specific case 4)

The first column has a formula in it in rows 3 and 4.

 

Previous workflow:

1. User deletes all content from rows  5+

2. User copies data from a spreadsheet range (21 columns wide) into the 5th row, 2nd column.

3. All data is pasted correctly. The first column's formulas all auto-fill.

 

New behavior:

1. User deletes all content from rows  5+

2. User copies data from a spreadsheet range (21 columns wide) into the 5th row, 2nd column.

3. All data is pasted correctly. NO AUTO-FILL.

 

If I paste TWO rows of data, auto-fill works.

SOMETIMES, if I paste more than two rows of data, the first new row will auto-fill but the remaining do not.

 

I suspect this is related to changes on the server side.

 

Every row that I paste, whether one at at time or in a batch should check for auto-fill and update accordingly.

Like it used to.

 

Craig

 

Tags:

Comments

  • Shaine Greenwood
    Shaine Greenwood Employee
    edited 01/20/17
    Options

    Craig—please contact Support@Smartsheet.com for this issue so they can troubleshoot accordingly.

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    Options

    Already sent.

     

    Craig

  • Tim Meeks
    Tim Meeks ✭✭✭✭✭✭
    Options

    Craig,

     

    Let me know when you get a resolution. I've setup similar with users copying/pasting data into sheets with formulas at the top so they formulas autofill.

     

    thx,

    tim

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    edited 01/25/17
    Options

    @Tim -

     

    No resolution yet.

    The process has been slow - got a response late on Friday but due to the time difference, I did not see it until Saturday. No response from my response until yesterday.

    And they say they can't reproduce it. I can. Every time.

     

    1. From OpenOffice, copy (Ctrl+C) to clipboard.
    2. In Smartsheet, paste (Ctrl+V) to sheet.
    Autofill does not work (there are about 100 rows being pasted)
    3. Copy content from Smartsheet.
    4. Delete rows added by (2) above.
    5. Paste content back into Smartsheet.
    Autofill works.
     
    Autofill in (2) for limited number of rows works.
    But I'm not going to test how many because if it works for 3 it should work for 100 or a 1000.
     
    Craig
  • Shaine Greenwood
    Options

    Hi Craig,

     

    Can you confirm that the formatting of your formula, including any quotes "" are the same, plain text format? I've seen in the past where quotes are combined with rich and plain text formats, which make the formulas different—Smartsheet needs plain text.

     

    Otherwise, you might have to keep trucking along in the Support process, maybe getting a screensharing session going with one of our reps in the morning. We're in the Pacific time zone here.

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    Options

    The formula is in rows 3 and 4 in Smartsheet.

    I am not copying the formula.

     

    Craig

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    Options

    And again, limited numbers of rows work.

    I know 10 does.

     

    So the problem is when the auto-fill is called on a paste of multiple rows.

    By when, I mean sequence of execution.

     

    Safest would be on insert, before inserting the data to do a check on auto-fill criteria is met. Do the insert. Return to new rows and if no data entered, update via auto-fill for all new rows.

     

    Craig

     

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    Options

    Support can reproduce this and it has been turned over to development.

     

    Craig

  • J. Craig Williams
    J. Craig Williams ✭✭✭✭✭✭
    Options

    Update:

    Development has verified this is a bug associated with "the number of cells being copied and pasted"

     

    They did not say what the number was.

    I was pasting 20 rows by 105 columns.

     

    I also got fails with fewer columns but won't bother determining the cross-over point.

    This is on their backlog list now, but no idea when/if it will be resolved.

     

    Craig

     

     

This discussion has been closed.