Contact list format

Dominique Rose WintherDominique Rose Winther ✭✭✭✭✭
edited 10/01/20 in Formulas and Functions
10/01/20 Edited 10/01/20
Accepted

I'm trying to use the text contact list for something, but when I ask it to convert the contact list cell to text and put it in the next cell so I can use it, it is very random in how it "translates" the list - some have quotes and some don't. After some thinking, it appears that if the names have a comma in them (i.e. last name, first name), then it adds quotes to show its not the next entry. (photo below)

That works if you're looking at it, but makes any data exercise hard to navigate because it isn't uniform. Not to mention my OCD it acting up every time I look at the Contact List column - they aren't in the same format and style.

I want to fix that but unsure how - I had initially imported an incorrect contact list in My Smartsheet Contacts, then deleted those and have entered the correct ones, so in My Smartsheet Contacts, they are all correct. And they don't have the incorrect capitalization (which existed in the old list that I imported, but now doesn't).

Some of these people don't have accounts yet, but quote a few do and those that do also don't have a similar format of their name (i.e. in the list below, Ben has an account, but has last name first, while Anna, Ashleigh, Adrienne also have accounts but have First Name then Last Name).

Question 1 - Can anyone tell me what am I missing to get these all aligned? Has anyone else faced a similar issue?

Question 2 - When I have many people using the system and they enter Team Members in the Contact List column, will they all convert the same way to the text column? For example, if someone changed how it was stored in their contact list, would that change the text and therefore they would see a different formula than what I see?



Tags:

Best Answer

  • Dominique Rose WintherDominique Rose Winther ✭✭✭✭✭
    Answer ✓

    Oooooo, I figured it out. I'd built the sheet a long time ago and I had inputted a list of restricted contact list people to choose from in the Column Properties. Once I removed that, it defaulted to the original settings.

    Whew - solved.

Answers

  • Hello @Dominique WINTHER ,

    Upon further testing of the issue highlighted, this is definitely related to those with names separated by a comma.

    In addition to this, I was unable to find a way to remove the quotation marks with a Formula.

    In this instance, I would raise an Enhancement Request here :https://help.smartsheet.com/articles/2476161

    You may want to reach out to these individuals and have them re-arrange the way they display their name within Smartsheet, or temporarily, you could add duplicate contacts to your system with their first and last name without a comma. When adding this duplicate contact, and you use the same email address, it should still show their Smartsheet Profile Icon as well as allow them to receive emails from notifications.

    With regards to your second question, it should show the name that individual has entered into the column. For instance, if I were to enter Sean Morgan as a contact with the email [email protected], and you were to add this contact to your contact list as Morgan Sean, with the same email, it will show what I entered to begin with, but you too could also add your own instance of Morgan Sean as its your own contact

    Let me know if you have any questions

  • That doesn't seem to be consistent with what I'm seeing. For example, in the example I gave, Ben H.'s name converts to Last Name, First Name. But in my address book, it is stored already as First Name Last Name.

    Also, in my admin Group Management, it shows an entirely different option.

    Can you help me to work out where the name formats are pulling from, in general and for him specifically, and why isn't it consistent with how the other names are put in?

    Screenshots here


  • Dominique Rose WintherDominique Rose Winther ✭✭✭✭✭
    Answer ✓

    Oooooo, I figured it out. I'd built the sheet a long time ago and I had inputted a list of restricted contact list people to choose from in the Column Properties. Once I removed that, it defaulted to the original settings.

    Whew - solved.

  • Hello @Dominique WINTHER !,

    My apologies for the late reply.

    With this type of inconsistent behaviour, I feel that it may be best that you reach out to our Smartsheet Support Team so they can review and confirm they behaviour.

    You can contact our team here: https://www.smartsheet.com/contact

    Kindest Regards

    Sean

Sign In or Register to comment.