Dynamic view - 'Save' button is greyed out

Hello all,

When I create a dynamic view and try to make any change to the data in it after that the 'Save' button is greyed out and it is impossible to save any changes at all.

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Ivet Vutova

    Would you be able to provide a little more information? Screen captures of the view & each page of the view set up would be the most useful (but please block out any sensitive data).

    Do you mean that the "Save" button is greyed out when you're actually working within the rows of the view, in the Details Panel, or is the "Save" button greyed out when you're setting up the view, at the beginning?

  • Genevieve P.
    Genevieve P. Employee Admin
    edited 01/13/21

    Hi @Ivet Vutova

    To follow-up, I checked in with our Support team and it looks like you've already opened a ticket with them on this issue. This is the best avenue to troubleshoot what's going on as they'll be able to help you one-on-one and view screen recordings without you needing to block sensitive data.

    Cheers!

    Genevieve

  • I am having the same problem. I had a view working just fine until today, and suddenly no one can save changes. I created an entire new view, identical to the first, but that one also won't allow saving. I cleared the data out of the sheet and pasted it back in - still can't save. I tried pasting data back in field by field. Still can't save.


    I had the same problem a few weeks ago when building my first sheet, and I contacted support but they could not figure out why it wasn't working the way it should. All the settings were correct and the column types had no issues...that time I cleared out the sheet and started fresh and that fixed it, but doing the same this time is not fixing it. And we are in the middle of the first live use of the view to run a key process, and not having this functionality is having a sever impact on operations...


    Thank you in advance for any help!

  • Hi @Anna Hernandez-French!

    I had absolutely the same issue - I was duplicating the views and I was continuing having the problem.

    Unfortunately I can not tell you how I fixed it because it somehow fixed it by itself. Now I am facing different issues relating to the data that it is supposed to be in the view but it is not for some reason.

    SmartSheet please do test the environment and try to fix those.

    Thank you!

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Anna Hernandez-French and @Ivet Vutova

    It would be very useful to know if this is potentially a browser issue or a browser extension, or if it has something to do with the sheet configuration. Screen captures and screen recordings will be the best way to look into these issues, so it would be ideal if you could continue to work with Support in a private channel. Keep following-up with the emails they are sending you and the information needed. The more detail, the better!

  • Hi @Ivet Vutova ,

    I had this same issue, but then discovered that in my Logic area, I had a rule that was not completed yet. Once I deleted that rule, I was able to Save successfully. Maybe there's something going on in another area that still needs to be completed?

  • Hello. I am the admin on a dynamic view. One of my users is unable to save any changes she makes to the dynamic view as the save button appears but is greyed out. No other users are having any difficulties. She has the same permissions as the rest of the group. Any help would be very much appreciated.

  • Ruby Chu
    Ruby Chu ✭✭✭✭

    Hello, I facing the same issue in Dynamic View. I shared Dynamic view to me teams and external stakeholders without sharing sourcing sheet. Some people are ok to make edit in Dynamic view, but some can't, their save icon is grey out. Can you please solve the issue or advise how to solve it?


    Thanks.

  • Sing C
    Sing C ✭✭✭✭✭✭

    Hi everyone,

    I know this is a dated discussion but it's the one I've found with the most comments about the subject. We had seen this sporadically without any pattern, having checked the things that different threads had suggested: browser, user, differences in the data for records that could be saved versus those that couldn't, etc.

    Raised a support case a couple of weeks ago and pleased to say the team got to the bottom of it. The issue we had related to the removal of names from contact list fields with the Restrict to list values only selected

    In our case, it was the Executive Sponsor column in our Demand Management sheet. We had a list of names, A, B, and C, and as intakes were submitted with only A, B, C, no problem. Changes made in Dynamic View were saveable.

    C would later be removed them from the list of allowable values in the column (so no further intakes could be submitted with their name) - they could have left their role, etc. However, we still had records with C as the Executive Sponsor. It was changes to ANY OTHER fields for rows that still had C as the Executive Sponsor that couldn't be saved.

    Hope this helps anyone in a similar bind.

    Thanks!

    Sing Chen

    Process Architect, Ceridian

    LinkedIn