Microsoft Teams Integration Issues - Not Receiving DMs/Teams Notifications

Hi All,

I'm having an issue regarding my Teams integration. I have set up the permissions, but am still not receiving them. I have uninstalled and reinstalled the app several times, to no avail. I want to show a quick comparison based on the Help article.

I am able to find the Smartsheet app in the Teams searchbar. But when I click on the Smartsheet bot, I do not see step 2 (as seen below in the Help article)

Ratner, it just asks me to go straight to Allow Access, and then to this site:

Is there a step I'm missing? Even if I allow access, I'm still unable to receive DMs when I do an @mention (even after creating an automated workflow). Not sure what the next step is, here. Please advise. Thanks!

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Andrew Ratner

    Yes, you need to first Allow access between Smartsheet & Microsoft Teams before then moving on to steps 2 and 3 in the Help Article.

    After you've moved past this pop-up screen and Allowed access, are you then able to toggle the Bot to say "Yes", like in the first image?

    You may also want to check the Automation Permissions on the sheet that contains the workflow you've set up as well, to make sure that it's set to Unrestricted (see here).


    If this hasn't resolved the issue, I would reach out to Smartsheet Support with multiple screen captures and detailed steps of what you've tried so they can troubleshoot this with you one-on-one in a private channel.

    Cheers!

    Genevieve