Alert Automation Comes Up In Error

Options

Hello,

I am having issue with an alert workflow where the workflow errors out. I have created a template for an internal process where we would create sheets to review and implement Deviations in our production flow. Upon creating a new sheet from the template and viewing the "Manage WorFlow" window, one of the alert workflows is errored out.

The idea is we would attach a PDF for review and change the status of a row as "Complete". The changing of the status to "Complete" changes the "WorkFlow" column cell value for the row from "NoWorkFlow" to "WorkFlow2". This in turn should activate the alert workflow. However, upon opening the newly created sheet from the template and viewing the workflows, the initial alert is errored out.

There is a similar work flow that would happen after everyone has approved the attached PDF by changing there specific status to "Complete". When all parties mark their status as "Complete", another row in the "WorkFlow" column would change from "NoWorkFlow" to "WorkFlow1". This in turn activates another alert workflow. This one seems to work every time and because there really isn't much of a difference between the two, it seems odd that "WorkFlow2" doesn't work.

See supporting pictures below






Any help would be greatly appreciated!

Answers

  • Debbie Sawyer
    Debbie Sawyer ✭✭✭✭✭✭
    Options

    It looks to me like the issue is with the recipients.

    In the one that fails the workflow is being sent to a specific person and in the one that works it looks like the alert is going to everyone that is shared to the sheet.

    When you are using a sheet as a template, the workflow manager is asking you to confirm whether the specific person named in the workflow is still valid and hence disabling the workflow until you have confirmed the recipient is still correct (in the newly created sheets)

    You could combat this by introducing a helper column into your sheet with the name of the person that needs to receive the alert entered on each row. Then set the workflow to send to contact in cell then pick that helper column, instead of using Send to specific person.

    Does this make sense or fit with your thoughts?

    Kind regards

    Debbie

  • Shawn Boucher
    Options

    Hello Debbie,

    I was thinking because the template and generated sheets are in a WorkSpace that the recipients are a part of, that the Alert to specific people would work.

    I changed the alert so that it should alert all those who are in the the "Assigned To" column. In testing this however the automation doesn't seem to be sending the alert. However, I am no longer getting the error since changing from alerting specific people.

    Appreciate the help!

    Shawn

  • Debbie Sawyer
    Debbie Sawyer ✭✭✭✭✭✭
    Options

    Hi Shawn

    When testing automation one tends to perform the action and expect the alert to come to oneself. This sometimes backfires (fails to send) if in our personal settings we have the box set to NOT notify us of changes that we make :D (which is logical in normal practise but annoying when testing!)

    Check whether this is what is causing your alert NOT to send to you in testing your automation.

    You will find the dialog box the following way.

    Go to the top right corner of your Smartsheet screen to the little circle with a head and shoulders image (or your photo if you have put one in). Click on the icon and select Personal Settings.

    Click the Notifications heading on the left side and check the tickbox at the bottom of this screen:

    Ensure that this box IS including your changes. Then Save and retest.

    Good luck - hope this helps!

    Kind regards

    Debbie