Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Can I stop auto delete data in cell


I lost my data in the cell that I choosed it. When I select the cell that has some data for a while, text will disappear. I have to undo to get data back. I am not sure, this is only my problew or another users have it. Please fix this problem as soon as possible cause it is very unconvenience for users and has high risk about accuracy of data.


  • Shaine Greenwood

    Hello Rueparade,


    Please contact our Support team to troubleshoot this issue: https://help.smartsheet.com/contact

  • Ok... i've switched to a DELL mouse to remove any concern about hardware.  I'll troubleshoot mouse MODE as that appears to be the most viable lead.    As of now, I can repeat this behavior with a Dell USB mouse by simply placing it in any cell.  releasing my hand.  within 5sec, the cell contents is gone.  very disturbing.  I've not observed this behavior any other place.

    NOTE:  please do fix the logitech driver issues... that is not acceptable as a major suppliers of mice and keyboards.

  • Shaine Greenwood

    Hi Doug,

    The Logitech driver issue is longstanding, and the root of it is specifically the Logitech driver configuration—which we can't change. (Trust me, we'd love to fix this issue but we're unable to fix Logitech mouse/driver behavior.)

    It sounds like you're on track to troubleshoot. You're welcome to contact our Support team if you run into any snags.

  • danestra

    I opened a case for this as I get the same situation. I use Chrome, not sure that's relevant, if others can pitch in which browser they use... btw the mouse is irrelevant. If you hit F2 on a cell then enter (i.e. not making any changes to it) and wait 5 seconds, the cell below it will auto-delete.

  • Carolynh

    I am seeing the same thing.  I did report this to Smartsheet and they said it was not Smartsheet.  I disagree since this only occurs in Smartsheet, no other application.  I tried without my Dell Mouse and even just used my laptop keyboard and same issue.  My IT team even remote-desktop'd into my laptop and he saw the same results.   I think this really is a Smartsheet issue.   I can replicate this about every 50 seconds.  I just sit there and watch my screen and poof, the data disappears wherever field the mouse is sitting on.   

    My SS Case was closed so...I'm hoping if others report this issue, SS will start to really look into.  

  • Shaine Greenwood
    Shaine Greenwood Employee
    edited 04/02/18

    Hi All,

    One other thing to make sure is that the browser or third party applications aren't causing this issue. There are certain browser extensions that can interfere with Smartsheet and we've seen some third party apps (one called Caffeine, for example) that have been known to delete data unexpectedly. 

    Turn off all apps and make sure just the browser is running; try a different browser and disable all extensions in your browsers. This will help isolate the issue.

    After trying the above, please also reach out to our Support team for further troubleshooting. Even if you have already reached out to them and they closed the case, please contact them again and let them know that the issue is still happening.

    If you end up isolating the issue to a browser extension or third party app, reply back in this thread so other community members are informed!

  • Just today I came across the exact same issue as described above and I need some assistance, please.  

    I have been using Smartsheets since May of 2017 without this problem. This is the first time this behavior has manifested itself.  Some information that may be useful:

    Windows 10 just pushed an update to me on 9/29/2017.  First time going into Smartsheet since that happened and I now have this issue with the cell contents being automatically erased after about 3-5 seconds with the cell selected.  

    I have used Smartsheet in Chrome browser up until this point.  Today is the first time I see the issue.  

    Based on te above Forum entry, I tried without a Mouse.  Error persisted.

    I tried some Browser changes:

    1) Tried again after disabling all Extensions and starting Chrome again.  Error still persists.  

    2) Tried Microsoft Edge.  Error exists there as well.   

    3) Tried Internet Explorer.  Error exists there as well.   

    4) Tried Mozilla Firefox.  Error DOES NOT occur in Firefox.  

    The good news is, I have a way to keep working with Smartsheet, which is essential to my job.  The bad news is, I do not want to have to use Firefox for one application on my system.  I would ask that Smartsheet development team figure out why this does not work and come up with a fix as quickly as possible.  

    Thank you. 

    Walt Svarczkopf



  • One other addition.  I also just ran Smartsheet, using Chrome, with Extensions Enabled.  That also DID NOT exhibit the behavior of clearing the cell contents.  Hopefully these clues provide some insight into what to do to fix the problem. 

    Thank you. 

    Walt Svarczkopf

  • AndrewGolden

    I just noticed this happened starting yesterday 10/9/2017.  I have been using SmartSheet for years and have not had this issue.  This is a pretty debilitating problem.  Every cell I select auto-deletes its contents.

    I've tried the workarounds above.  I disabled all Extensions in Chrome and I still get the same issue.  

    Are more people not having this problem?  Have we found a solution?



  • Andrew... Have you tried Firefox as a browser?  That is the only solution I have found that works.  It's a bit of a pain having to use a different browser for Smartsheet than I use for everything else, but at least I found a way to keep working.  

    I see there is an updated to Smartsheet scheduled for the 28th.  No idea if this is being fixed or not.  

    Can we get an answer from Smartsheet support about this, please?  I would think that your customer's ability to use your product, that they are paying for would be a HUGE issue for you to correct.  PLEASE RESPOND.

  • Navdrovya

    It seems like it only happens with Chrome for me, with or without using caffeine.

    Maybe this is something that SS should take a look at and see how to fix.

    Very disturbing to unknowingly lose some data which could go unnoticed for sometime before being realized, which we know will be at the exact wrong time. 

  • Shaine Greenwood


    To troubleshoot this, I'd recommend making sure that you've updated Chrome to the latest version. More info on how to update Chrome is available on this Google support page: https://support.google.com/chrome/answer/95414?co=GENIE.Platform=Desktop&hl=en

    Otherwise, it's likely that a browser extension is causing this issue. Try opening Smartsheet in an incognito window (steps on that here) to see if the issue still occurs. If it doesn't, then you'll want to disable all of your browser extensions (info on doing that here) and enabling them one-by-one until you see the issue happen again. Once you determine the extension causing the issue, then you may want to leave it disabled.

  • kristapenland

    I am having this same problem.  I don't have any third party apps and have tried several browsers.  I have now officially sent 3 online requests for help and have not heard back once.  

  • luigi

    same thing here, windows 10 latest version, unpdated browsers, logitech wirwless mouse

    video of the issue here


This discussion has been closed.