Generate Documents - Wrap text

02/09/21
Answered - Pending Review

I just started using the Generate Documents function, but immediately something came up for which i can't get my head around it. I have a field wich i fill with a small piece of text. No longer than 2 sentences. The column for that piece of text is set to wrap the text. However, when i generate documents from a fillable PDF, on that same field, instead of wrapping the text as per normal, it just types a continuous line that ends up going off screen.


Any workarounds on this?

Answers

  • Hi @Jose da Silva

    You note that the Smartsheet Column is set to wrap-text, but is the PDF form field configured to be multi-line as well? If it's not, please configure this field in your PDF to be multi-line and see if this resolved your issue.

    Let me know if this works for you!

    Cheers,

    Genevieve

  • Jose da SilvaJose da Silva ✭✭✭✭✭

    Hi, thanks for your tip, but it doesn't really solve it. By default the field that i've created is set to multi line

  • Hi @Jose da Silva

    If you can confirm that the fillable field you're mapping to is configured to allow multi-line values, I would suggest reaching out to Smartsheet Support.

    This way you can provide them with a screen capture of your sheet and of the document created, as well as providing an attachment of the fillable PDF so they can test and replicate your issue in a private setting.

    Thanks!

    Genevieve

  • I have experienced the same challenge with this! I have tried both Nitro and Adobe Acrobat Pro and have ensured that 'multi-line' is enabled. Did you find a resolution? I have tried everything and would appreciate any tips you have. Thanks!

  • Did we get an answer to this I’ve mapped my file, which text boxes are multi line, and the column is also wrap text. However Smartsheet document creator only seems to pull in the cells data if that cell is a limited number of characters.

  • heidi_flores86196heidi_flores86196 ✭✭✭✭✭

    I'm trying to use Document Builder and having the same issue. How do we fix this?

  • This worked for me. You need to change the PDF forms

    "People also ask

    How do I wrap text in an Adobe fillable form?

    3 Answers. Tick the Multiline option and un-tick the "Scroll Long Text" option under the field's Properties - Options tab. Word wrap is not the same since there is no field bounding the words. If you want a from field to wrap the text within the field's boundaries, use the "multi line" option for the field.

Sign In or Register to comment.