Changing the UI language > does not seem to work


I would like to turn SmartSheet into english but it keeps on being displayed in french.

Changing this parameter as described here does not work:

Best Answer

  • Edouard Albert
    Answer ✓

    Actually I found out what the issue was: if you create a sheet and change the language settings afterwards, the change only applies to the main interface of Smartsheet but not at the lowest level, the sheet itself.