How Do I Preserve 'Long Date' Formatting When Using 'Generate Documents'?

Options

I'm in the process of attempting to build a document to be generated from our Smartsheet and am trying to pull in a date field. I have the date column on the Smartsheet set to a long date (i.e. March 16, 2021), but it is coming in on the form as 03/16/2021.

I have also double checked the fillable pdf I am using and tried changing the settings on the field from a text field with date formatting (mmmm, d, yyyy) to one with no formatting at all, and neither way is making any difference.

Any suggestions/workarounds?

Answers