Document Builder - Downloaded File Size


I understand you have to have a fillable PDF when using document builder to map your sheet fields, which already run as a large file. When I generate a document with the populated fields, the file size becomes much larger. Is there a way that the document builder functionality, when downloading, be a flat PDF file that removes all the dynamic fields? We use these generated documents to upload into our HRIS system and the max file size is 512kb. The downloaded docs are coming out to be 1+Mb.


  • Syed Muhafzal
    Syed Muhafzal ✭✭✭✭✭

    Hi Barbara, looking at the max upload file size of 512kb in your HRIS system, it looks like it is designed to specifically take .txt file or a small size pdf (or to a certain extent, CSV file). I am not sure if there is a way to reduce the size from Smartsheet itself, as the more data you fill in, the bigger the size will be. What about opening the pdf once generated, in Adobe and save as other / reduce file size and then upload to your HRIS system?

    Sorry if this is not helping :(

  • Hi Syed,

    Thanks for the response. This is what we're doing now, however, it's just an additional step in our process. We will continue to search for ways to make this a little smoother on our end.



  • aleever
    aleever ✭✭

    Hi @Barbara Duran, were you able to find a solution? We are having a similar issue that once we generate the document in Smartsheet, the size is too large to send to our system (max 10MB). Thank you!

  • Tamara
    Tamara ✭✭✭✭✭

    Our company is experiencing the same issue. However, it only seems to happen when we use the new Smartsheet desktop app. The document starts at 174 KB and once generated in the Smartsheet app becomes 4MB. Does anyone know if there has been a solution to this?

  • When you are in adobe Prep Form tool make sure not even one field has "Multi-line" selected. My version of adobe will not change them if you select them all and uncheck them, you need to go one by one.