how does the formula work for duration column when predecessor activated


I am getting a #invalide data type in some but not all rows.


  • Anupriya
    Anupriya ✭✭✭✭
    edited 01/13/22

    Can you share the formula that you are using for duration? Or is it the system Gantt column?

    If it is the system column, it should get automatically updated. Can you share a screenshot of the project settings?

  • Brent Bowser

    @Anupriya I am using the system column below is the screen shot you requested, thank you for taking time.

  • Anupriya
    Anupriya ✭✭✭✭

    The only reason that I can think of is a wrong date format. Other than that it should work fine.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Brent Bowser

    I've seen this happen before when there's a column with a Formula before Project Settings and dependencies were applied. Then if you enable Dependencies, the column that had the formula (which previously had an error) will still show that error.

    Try adding a "New Duration" column to your sheet, then adjust your Duration column in your settings to look at the new column that never had a formula.

    Once you have Duration in the New column, delete out this old one.

    Let me know if this fixes your issue!



Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!