Data Shuttle won't run manually or on a schedule after first instance

Options

I've been struggling with this for a day. I am offloading a Sheet to a Google Drive. When I create the workflow in Data Shuttle and click RUN, it runs fine. If I try to do it again, it seems to process the file, but it never updates in on Google drive. I can repeat this over and over, it will only run once. Ive tried waiting about 15 minutes, and it's the same result. Also, the scheduling just stopped working. It's seems to be working fine on a pre-exisitng Workflow though. What am I doing wrong?

Best Answer

  • marc4
    marc4 ✭✭✭✭
    Answer ✓
    Options

    I assume you are writing out the file with the same filename? On google drive it will overwrite the exiting file. Does the date time stamp change? If you right mouse click you can see "Manage Versions". Does it show multiple versions of the file?

    Also, after the first run did you delete the file from Google Drive? If so, then check the trash to see if the file now has multiple versions. Once smartsheet writes out a file, it updates the file by file id, not by name. So if you move/delete the file it does not write out a new file where you are expecting it.


    /marc

Answers

  • marc4
    marc4 ✭✭✭✭
    Answer ✓
    Options

    I assume you are writing out the file with the same filename? On google drive it will overwrite the exiting file. Does the date time stamp change? If you right mouse click you can see "Manage Versions". Does it show multiple versions of the file?

    Also, after the first run did you delete the file from Google Drive? If so, then check the trash to see if the file now has multiple versions. Once smartsheet writes out a file, it updates the file by file id, not by name. So if you move/delete the file it does not write out a new file where you are expecting it.


    /marc

  • Fredster
    Options

    Thanks, Marc4. Based on your questions I figured out how it operates. It is working great now!