Microsoft Teams- Smartsheet needs admin approval

Options

So I have added the app to my Teams Windows client. When I go to add a smartsheet to a team, I get prompted with Smartsheet needs admin approval. I am the "Team" owner as well as an Org Admin since I am the Teams administrator. Permissions from TAC show that we Allow all apps and when I search under Manage apps, Smartsheet is Allowed. But again, when I try to add Smartsheet to a Team channel, I get the needs approval pop-up. I click on Grant Permissions but nothing happens and the Save button stays greyed out. What am I doing wrong here?


«1

Answers

  • Stephanie B
    Options

    Not an answer... but this just started for me as well. I was able to add to add Smartsheet to a channel last week, but this week, I'm being asked to "Grant Permissions" and when clicking, nothing happens. I've tried to do this on multiple channels and get the same result.

  • Paul Jerdee
    Options

    Stephanie, I just found this morning that if you use the web version of Teams, it will work fine. It only appears to be an issue with the Windows client version of Teams that this is an issue.

  • Stephanie B
    Options

    Thank you! I'll see if I can get that to work. Appreciate you responding. :)

  • Ryan A
    Options

    There seems to be a problem on the Microsoft side. I created a channel in Teams from the client app and it is not shown available on the web. I suspect a service disruption that may have caused this issue.

  • GregoryMuir
    Options

    I'm getting that problem even when on the web. I haven't had to add it in a while but it worked just fine for me the last time I did it.

  • JCrane
    JCrane ✭✭
    Options

    I am having the same issue today. I will try the web version now.

  • Susan Papali
    Susan Papali Employee
    edited 11/30/22
    Options

    Hello everyone,

    I'm Susan, and I'm a Product Manager on the MS Integration team here at Smartsheet. I'm sorry that you are running into issues with granting permission for the new tabs integration. Our engineering team is working on a fix to resolve the inactive "Grant Permission" button on MS Teams desktop clients, and we expect to release the fix ASAP. In the interim, you should be able to "Allow Access" from the web browser.

    Thanks,

    Susan Papali

  • Stephanie B
    Options

    I was also getting the same issue using the web version. I finally found a workaround - by adding it using the "Website" app in Teams vs Smartsheet. I copied the Smartsheet URL and added it that way. But I had to ensure the sheet itself was set to "Publish" and "Allow anyone with a link...". Not ideal, I'd prefer to link directly using the Smartsheet app in Teams. But it seemed to work for me, for now. But looking forward to a fix. Thank you.

  • Marcia562
    Marcia562 ✭✭✭✭
    Options

    @Stephanie B What do you mean by "by adding it using the "Website" app in Teams vs Smartsheet."

  • Bex
    Bex
    edited 08/31/22
    Options
  • Marcia562
    Marcia562 ✭✭✭✭
    Options

    @Stephanie B THANK YOU!!! That worked. I can't wait until this issue is fixed.

  • cnde
    cnde ✭✭
    edited 09/01/22
    Options

    @Susan Papali Is there any update on this issue? I get the same "Grant Permissions" page on both the Teams app and webpage (as you suggested). I have all sufficient permissions to add smartsheets to teams, and had no problem doing so approximately 1 week ago. Any update or suggestions?

  • Susan Papali
    Susan Papali Employee
    edited 11/30/22
    Options

    Hi All, Thank you for your patience while we work on getting this bug fix out the door. An updated version of the app with the fix should go live within a day or so. But in the interim I wanted to provide some more details instructions about how to approve the app and get the tabs added.

    1) An IT admin will need to grant tenant-wide admin consent to the application. As per Microsoft, To grant tenant-wide admin consent, admins need:

    • An Azure AD user account with one of the following roles:
    • Global Administrator or Privileged Role Administrator, for granting consent for apps requesting any permission, for any API.
    • Cloud Application Administrator or Application Administrator, for granting consent for apps requesting any permission for any API, except Azure AD Graph or Microsoft Graph app roles (application permissions).
    • A custom directory role that includes the permission to grant permissions to applications, for the permissions required by the application.

    2) The IT admin will get prompted to approve the app when they try to add a new Smartsheet Tab


    Note that your admin will need to take the above steps even if they have previously approved the Smartsheet App. We understand this is not optimal and causes unnecessary friction in the approval flow, and I want to assure you all that we are currently working on a fix that will make the approval process easier.

    Thanks,

    Susan Papali

  • Susan Papali
    Susan Papali Employee
    edited 11/30/22
    Options

    Hello again 👋

    The fix went live and the "Grant Permission" button should now work for you. As I mentioned above you, an admin will need to first grant permission to the new Smartsheet Tabs app by clicking on the + button in the Teams channel.

    Thanks,

    Susan

  • Randy B CDN
    Randy B CDN ✭✭✭✭
    Options

    Our Teams environment is in a shared tenant and has more governance than normal. Adding Teams apps require approval from all tenant partners and can be a lengthy process. When this issue came up out admin said we needed to get the app re-approved. My question is - was there a change to the permissions required by the Smartsheet app or are they the same after the update that cause the issue? If yes, I need to go through the process, if no I should be able to get it turned back on without issue.

    Thanks

    Randy