Generate Document - Text Shrinking in Field set to Multi-line



Bit of an odd problem!!

When generating a document, text in a field shows as one line and the text shrinks. The pdf form field is set as Multi-line.

What I have found is when the field is the only one mapped in the document generator, the text display as Multi-line. The moment I map others the text goes to one line and shrinks.

Any thoughts would be much appreciated.



  • Richard King
    Richard King ✭✭✭✭
    edited 10/04/22


    Solved the issue.

    I have changed all the PDF fields to a fixed font size and not Auto and the document is now filling correctly.

    Where any field is set to Auto this appears to affect the whole document including the Multi-line.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Richard King

    I hope you're well and safe!

    Excellent! Glad you got it working!

    Be safe, and have a fantastic week!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Please support the Community by marking your post with the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: | | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • L Darvesh
    L Darvesh ✭✭✭

    @Richard King Hi, I'm having a really hard time with the font sizes in 2 text fields, mainly because they are for approx 1 or 2 short paragraphs of copy. Smartsheet seems to not be able to handle this. It also overrides the settings I made to the fillable PDF in Adobe Acrobat. I set all the fonts to 12 point but when I have long text Smartsheet can't handle it.

    I read your response saying you'd fixed it. I don't see any option to make copy either auto or non-auto. I set to 12 point in Adobe and then the field height to 0.2 (I read that fixing the height of a field is what controls the point size, but obviously for a long copy response in a field this is not an option.

    I found out today that Scrolling is NOT supported by Smartsheet. Hope this helps anyone else reading this. I tried switching on and off the Multi-line option, and also 'locking' the options. No joy.

    I've had a call with Smartsheet support but they were unable to help me until now.

    If you have any other insights I would be extremely grateful.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!