Lot of time is needed to automatically update values on the dashboard.


Source sheet has been updated with new values. The updated values in the source sheet are not refreshed in the dashboard, it is taking more than half an hour to update with multiple refresh.


  • Mike TV
    Mike TV ✭✭✭✭✭✭

    @Swetha @Swetha

    Dashboards have a setting on the View menu at the top-left for "Auto-Refresh". Try setting that to 1 Minute or however you like setting it. If it's still not updating your sheet, submit a SmartSheet Support request. The community cannot fix that.

Help Article Resources

Want to practice working with formulas directly in Smartsheet?

Check out the Formula Handbook template!