Issue with printing when applying a filter

Umar Mughal
Umar Mughal ✭✭
edited 02/20/23 in Smartsheet Basics

Hello all

Hopefully not a naive mistake, but I have checked on previous Smartsheets I have set up and it is working perfectly

But on the latest project I am working on, when I apply a filter, the print (then the consequent PDF that opens showing the print preview) is blank? there is no information apart from a heading showing the dates

Without a filter, the print works perfectly

Have I made a mistake somewhere or is this a genuine glitch?

(pic attached of my glitched out print)


Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Umar Mughal

    Is it possible you have Hierarchy on your sheet, and all your filtered rows are actually child rows?

    For example, if this is my sheet:






    But I usually keep it collapsed, so I'm only looking at Parent Rows:

    Then I put a filter on so only Task 2 shows up (a Child Row), but I don't save the sheet:

    What this means is that this Child Row is actually still hidden/collapsed underneath the Parent row, since I haven't saved the sheet to expand the rows.

    If I Print at this point, I'll get a little warning:

    But I can choose to export anyway. If I do this, the Print window pops up and notice that the "Include Collapsed Rows" checkbox is automatically un-checked:

    Meaning my Print would have no rows showing, since all my rows in the filter are currently collapsed:


    Does that make sense? In this instance you can resolve this in two ways:

    1. Check the box to show collapsed rows
    2. Save the sheet when the filter is applied so it expands all your rows


    Let me know if this resolved the issue!

    Cheers,

    Genevieve

  • Many thanks for taking the time out to help Genevieve

    As it worked on a Smartsheet i made last year, I don't think so (i did try showing collapsed row option)


    Laura McDonough solved the issue for me

    I present an extract from the email i was sent below (emailed 20/02/23 to Umar for future reference). A video was linked in which is not showing here

    " I've done some testing and created a short video of how I was able to print via task name, so you can replicate. Please see here. I'd note at the end I change back to Multi Select.

    As an overview as to why it was showing blank originally and after trying my old Microsoft account and had the same behaviour. Essentially, it's two things 1. PDFs/ the technology is separate to Smartsheet and Microsoft , and therefore the same concepts and rules we apply in a sheet and report don't apply within a pdf 2. With point 1 in mind, the column in question is 'Multi Select' and with the PDF it also requires a definitive value i.e. it's this and no one and as filtering does not apply to Pdfs that is why it was showing blank.  "