Data Shuttle Offload is putting numbers as text with preceding apostrophe in excel format output


I am using Data Shuttle to offload a work order number (primary column in sheet) and it's associated start and end dates in an excel format. Everything is working fine except that the work order number is in a text format with a preceding apostrophe instead of an actual number. This is causing downstream automations to fail as they are coded to expect a numerical value for the work order.

I tried a helper column with the formula =VALUE([Work Order]@row). Formula works great in my sheet, but I have the same problem when the excel file is created. So it appears that even if a cell is a number in the sheet, it will get written as text by Data Shuttle when writing in an excel format.

Any ideas are welcome. I would much rather fix this in Smartsheet than in any automated routine that requires an excel format or convert all our automation to use CSV instead of excel formats.

Thanks in advance!



  • TomG
    TomG ✭✭✭✭✭

    This morning, I updated my extract with additional numeric columns and they behave the same way. Numbers are written as text when using an excel format for a Data Shuttle offload.

  • TomG
    TomG ✭✭✭✭✭

    After working with Smartsheet support, they have indicated the issue is related to the compiler and they have an open case being worked with Microsoft. This has been an open issue for multiple months and has been escalated but there is not yet a timetable for resolution.

    So until then, it must be addressed with solutions outside of Smartsheet or using the CSV format.