Offline forms not uploading when connection established

Options

Hello

I have a colleague that used the offline form function in the App as directed, captured a lot of data in 7 forms offline, but the data then sat on their phone and never uploaded itself despite them re-establishing a wifi connection. We have successfully used this function elsewhere so not sure what happened in this instance. Has this happened to anyone else and what are the things to avoid? Any suggestions? Thanks in advance



Answers

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Simone Dewell

    Has the form submitted since you posted this?

    Based on the image provided, it looks like the wifi signal is really minimal at the time of the picture (only one bar). At this point I would expect the signal needed to be stronger for the submission to be successful.

    I hope that helps!

    Genevieve

  • Dave Brophy
    Options

    Hi @Simone Dewell & @Genevieve P.

    I have been experiencing this exact problem. Multiple users of a Form are unable to upload some of the records when they come into mobile phone range. This has happened to a small % of our records but I have not found a solution yet.

    I am led to believe the records are still on the phone(s) but until we see these feeding into the database, I am nervous.

    Got this response from Smartsheet:

    " May I kindly ask for you to create a duplicate copy of the affected form and try to reproduce the issue on the copy of the form. You can duplicate a form by navigating in to Manage Form > Select the three dots to the right > Select "Duplicate" (This will create a copy of your form on the same sheet, but with a new URL) > Using the newly created duplicate, please try submitting form entries offline, then then re-establishing a connection to check if the problem still exists.

    Also, kindly try to create a copy of the Sheet by Saving it as New and try to reproduce the issue on the copy of the sheet."

    The problem here is that we can't be guaranteed the Forms don't upload! The vast majority do actually upload successfully.

    Have you found a solution?

    Cheers,

    Dave

  • Dave Brophy
    Options

    @Andrée Starå

    Hi Andrée,

    I have seen your responses on some of these discussions and would be curious to get your opinion about this issue. We have confirmed all users have up-to-date software on their phones.

    The issue is random and happens in a minority of cases but it is accumulating and we need the records feeding from the form to the sheet.

    Many thanks in advance,

    Dave

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Dave Brophy

    If your users are fully connected to the internet or if they have a strong mobile signal but the queued offline forms are staying in the "Offline" queue, then please do continue to follow-up with Support providing them with the troubleshooting tests they ask for.

    Since this is only happening to a small percent of your users, the most important information will be what phone type and version they have, along with what version of the Smartsheet App they're using. (e.g. iPhone 8, iOS 16.11, Smartsheet App version 11.0)

    This will help Support determine if there's a common thread between the phone type and app that requires an update or a fix.

    As a side note, you may want to ensure your users have the setting "Background App Refresh" toggled on for the Smartsheet App (see: Use mobile forms when you’re offline)

    Thank you,

    Genevieve

  • Dave Brophy
    Options

    @Genevieve P.

    Thanks for your quick reply. Looks like we're narrowing down the likely cause.

    Rgds,

    Dave