Email notifications sometimes get sent out via a random email address

Options
Dani Zhao
Dani Zhao ✭✭
edited 04/04/23 in Smartsheet Basics

We use Smartsheet as a ticketing system and we have a workflow to send out email notifications to ticket senders (who aren't Smartsheet users) as soon as a specific checkbox in a row record is checked. For some reason, the notification sometimes gets sent out via automation@app.smartsheet.com, which has been whitelisted in our email server and it's received fine; sometimes it's via a randomized email - something like xxxxx@bounce.smartsheet.com and it spoofs its address to appear as if it's from one of our internal email addresses. The spoofing behavior is blocked by our email server, hence the ticket senders can't receive email notifications sent from these addresses. I wonder why there's this inconsistency and if there's a way to fix it?

Best Answer

  • Dani Zhao
    Dani Zhao ✭✭
    Answer ✓
    Options

    After searching and investigating for weeks this has finally been resolved. The issue was that the notification workflow (with the trigger of "once the checkbox is marked") was triggered by a shared email account, which isn't a legit Smartsheet user. Hence the email notification got sent out in a weird way and anti-spoofing policy came into play. The workaround was to leverage "copy rows" workflow - have it triggered once the checkbox is marked and copy the row to a new sheet, then create notification workflow for records in the new sheet. This way the workflow gets triggered by Smartsheet itself, notifications get sent out via the automation@app.smartsheet.com email and users are able to receive the emails now.

Answers

  • Frank S.
    Frank S. ✭✭✭✭✭✭
    Options

    Greetings @Dani Zhao,

    In the automation, under the customize message section, there are 3 settings. If you want all messages to be consistent and from the same e-mail for whitelisting, I would confirm the messages are coming from the same setting.

    For your example, I would expect the setting to be Send from Smartsheet Automation.

    If you select "send from my organization," the e-mail used is automation@app.smartsheet.com.

    You may want to ensure that the automations are all set to the same setting; this could be the issue with different e-mails.

    Frank Smith, PMP

    Assistant Director | IT Special Projects Mgr.

    Oregon Parks & Recreation Department

    If my response helps, please mark it as an accepted answer. 😎

  • Dani Zhao
    Options

    Thanks @Frank S. for your reply, but I'm actually not able to see those 3 settings. I'm attaching a screenshot of what I have under Customize message section:

    Can you please advise?

  • Dani Zhao
    Dani Zhao ✭✭
    Answer ✓
    Options

    After searching and investigating for weeks this has finally been resolved. The issue was that the notification workflow (with the trigger of "once the checkbox is marked") was triggered by a shared email account, which isn't a legit Smartsheet user. Hence the email notification got sent out in a weird way and anti-spoofing policy came into play. The workaround was to leverage "copy rows" workflow - have it triggered once the checkbox is marked and copy the row to a new sheet, then create notification workflow for records in the new sheet. This way the workflow gets triggered by Smartsheet itself, notifications get sent out via the automation@app.smartsheet.com email and users are able to receive the emails now.