Columns not allowing a sum value

Hi All

I am having an issue creating a sum for a column that has $ figures in it. It will just give me the Count. this occurs when I highlight multiple cells, use a summary or when trying to use a rollup sheet.

I don't know if this is important, but these column figures are derived from a Data Shuttle workflow that collects the data from excel.

I have ensured that the mapped columns are "Number" in the column type (it was previously "Auto") with the same result.

Any ideas?


  • Kelly Moore
    Kelly Moore ✭✭✭✭✭✭

    Hey @andrew.taylor37161

    In the column shown, smartsheet believes the values in the cells are textstrings, not numbers. I can see this because the values are aligned left justified, not right justified. All SUM functions require numbers, Count functions can count anything.

    How are the values entered into the cells? If the values are inputted via a formula, which I suspect, wrap the entire existing formula, parentheses and all, in a VALUE function. You will add the function parenthesis at the start and end of your existing formula. You should be able to turn on the currency format for the column if it doesn't automatically show.

    =VALUE(your entire formula with all the parentheses)

    Did that fix it for you?


  • Hi Kelly

    Thanks for your suggestion and I tried what you suggested, but the data isn't a formula in this column, it is just populated via Data Shuttle. I don't know if that is why it appears as a formula (left aligned0, although I have other figures in other columns that also are populated by the same method and from the same source and they appear right aligned.

    After your suggestion, I decided to re-map Data Shuttle and chose not to adjust the Column type and it has fixed it.

    I do note that the data is right aligned now so your observation was spot on and lead me to the solution, so thanks greatly.