New Row Added Workflow Trigger not working when non-licensed user adds row

Options

Hi,

I have set up a simple "When rows are added" workflow, but it only triggers when I add a row.

Issue: when other users add a row, it does not trigger the workflow

Example:

Me (licensed-user/sheet owner) = User A

X (non-licensed-user/sheet Editor-can share): User B

Y (non-licensed-user/sheet Editor-can share): User C


When User B or User C adds a row, and saves the sheet, the trigger does not fire and no users receive the notification.

When User A adds a row, and saves the sheet, User A/B/C all receive the notification.


There were no restrictions added to the sheet (i have not really added restrictions to any sheet, as we use the default sys admin settings, therefore, it's confusing that for this specific sheet this functionality is broken, given it works just fine in other sheets for both licensed or non-licensed users).


Kindly let me what else I can do to resolve - I have deleted/re-built the workflow twice with no success).


Thank you!

Kim


Answers

  • Kiela
    Kiela ✭✭✭✭
    Options

    Kia ora,

    What are you setting for the notification? Double check the restrictions in the workflow, you may not have set them but the system does. I have found that is my issue in the past.

    Good luck

  • Kim S
    Kim S ✭✭
    Options

    Thank you! But unfortunately this did not resolve it. Changing the restrictions (between Restricted and Limited) did not change the issue.

    Users still receive notifications when I am the User that makes the change in the sheet, but when they make the edit, it does not trigger the notification (for anyone, myself included).

    So I am wondering why their changes do not trigger the workflow?


    Thank you again!

  • Genevieve P.
    Options

    Hi @Kim S

    Can I clarify how the rows are being added? Are you using a Form or manually adding content into the sheet?

    I see the trigger for your workflow is only set to when new rows are added. I ask because I'm wondering if your collaborators are adding content into blank rows (that previously had data) instead of NEW rows (that have never held any data).

    The first instance would not send an alert but the second would. Can you try creating a simple form and submitting a new row? If that form submission is entered in lower down in the sheet (with blank rows above it) then those blank rows aren't seen as "new". You'll want to delete these from your sheet so any added content goes into fully fresh, new rows.

    Let me know if that was the issue or not!

    Cheers,

    Genevieve

    Join us at Smartsheet ENGAGE 2024 🎉
    October 8 - 10, Seattle, WA | Register now

  • Kim S
    Kim S ✭✭
    Options

    Hi Genevieve,

    Unfortunately I don't think this is the issue, as when I (User A) add new rows (not replace existing row data) the trigger does work and all users get notified. The issue is when User B or User C or frankly all other Users go to add a new row, their entry does not trigger the notification to users that a new row has been added.


    It is because of this that I am uncertain why one user's entry would every time work successfully yet from all other users the trigger has never worked successfully.


    Thank you for your continued help and support!!!

  • Genevieve P.
    Options

    Hi @Kim S

    This does sound strange and I'd love to learn more so I can replicate what you're describing:

    • How are the others adding the row? (What actions are they taking - submitting a form or adding data directly into the sheet as Editors?)
    • Is the notification received in-app (in the bell icon)?
    • Have you tried the Form submission test, and if so, did the row appear where it was expected to appear?
    • Can you post a screen capture of the sheet showing a row that did not have an alert sent out?
    • Can you post a screen capture of the Activity Log showing the row added that did not send an alert?
    • Can you post a screen capture of the workflow showing the last time that it ran successfully:


    (But please block out sensitive data in any images!)

    Thanks,

    Genevieve

    Join us at Smartsheet ENGAGE 2024 🎉
    October 8 - 10, Seattle, WA | Register now