How to show Contact Names instead of email addresses in Contact Column in Sheet?

moraki
moraki ✭✭
edited 06/09/23 in Smartsheet Basics

Hello all.

I am using Contact Columns in my Sheet, where we add Contacts. There are two ways to add a row: either by submitting a form, either by inserting a row inside the Sheet. The problem is that often only the person's email is visible while we want to show the person's name.

From my research I found that you have to add this person as a contact in order for their name to appear in the Contact Column. However, I have already tried this and one email still doesn't have a name attached. I have added the name multiple times by double clicking the email field and editing the contact but that doesn't seem to do anything.

Is there some other thing I haven't found and is the key to make this work?

Thank you.

Answers

  • Hamza1
    Hamza1 Moderator

    Hi @moraki

    To show the name of the user you’ll want to add the user as a contact by following the steps below:

    1. In the Navigation Bar, select Account > My Smartsheet Contacts.
    2. To display the Contact form, in the My Smartsheet Contacts form, select Add.
    3. Type the name and email address of the contact, and select OK.

     After these steps, Smartsheet adds your new contact(s) to your contact list. Following this you can then start to type the name of the user in the cell of the Contact List column which should display the name of the user. Please see the following screenshots for reference:



    For more information on managing contacts please see the help article https://help.smartsheet.com/articles/796143-managing-contacts 

    In the event that you’r still experiencing an issue, please kindly provide screenshots of the behaviour you’re seeing and cover any sensitive information.

     Thanks,

    Hamza

  • moraki
    moraki ✭✭

    Dear Hamza,

    Thank you for your reply and the information you provided.

    As I see in your screenshot (the second one), when you start typing the email address, the name of the contact is not showing on the dropdown option below, only the email address. This is the problem I am trying to solve.

    I am attaching the same screenshots from my account but you can see that it is the same scenario as the one you described. I have added a user as a contact and yet, when I type their email, their name doesn't load/appear on the field. However for another user it works and shows their name. So I cannot understand the logic behind this.

    Do you have any other ideas on how I could solve this issue?

  • Hamza1
    Hamza1 Moderator

    Hi @moraki

    Pleas kindly note that if a contact has already been selected in the column with the email, and then you add the contact with the Contact Name, the email will still be an option because it appears in the column already. In the screenshot provided, once I start typing the name of the user, the email address also appears but when I click on it this will display the name of the user on that particular cell. Please see the screenshots below:



     

    When you type a name or email address in a Contact List column, the names that are displayed will include the following:

    • Any preferred contact values that you’ve set up in the Column Properties window.
    • All collaborators shared to the sheet.
    • Any other contacts or email addresses that have been assigned to other rows in the sheet.
    • People in your personal Smartsheet contacts list. (More information on this is available here.)
    • If you're a part of a Business or Enterprise account, other people that are in the account. (More information on User Management is available here.)

    For more information on the above please see this help center article.

  • KMarti
    KMarti ✭✭

    I have a similar question. I'm setting up a sheet where I want end users to enter their email address in the form, but once the form is submitted and the row is added to the sheet, I want it to appear on the sheet as the contact name instead of the email address. I have the users added to my contacts list. How can I accomplish this?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hey @KMarti

    What I would personally do here is have a "reference sheet" that has two columns: a Contact list column with all the users listed as Contacts, and a Text/Number column with their associated email address.

    Then you can adjust the Form's security settings so that the user has to log into Smartsheet to fill out the form, which then allows the form to automatically capture the email address (so they don't have to manually add it in) in the Created By system column in your sheet.

    Once you have the email, you can use an Index(Match formula to look into your reference sheet and bring back the associated Contact.

    If you only have a small number of users in the form, you could use an Assign People workflow instead, with the condition block checking the email address before assigning the contact.

    Cheers,

    Genevieve

  • Here is how I display contact NAMES instead of EMAIL addresses from scratch. If you already have the contacts added, you can skip down to "How to change the cell to show the contact name instead of their email address" in BOLD

    First, you need to click on "Account" in the bottom left corner.

    Then click on "My Smartsheet Contacts"

    This will open another window where you will click on the "Add" button and then enter the first and last name of the contact and their email address. Then click "OK"

    Now, go back to the sheet you are working on.

    Name a column in your sheet "Contact Name"

    Now, hover your mouse on the "Contact Name" column header and choose the 3 dots at the right of the "Contact Name". Then, choose "Edit Column Properties..."

    Now, choose "Contact List" and click "OK".

    Now, under your "Contact Name" column header, type the name of the person you would like to add for that row. The user that you added previously will show up as one of the options. Click on the correct name that pops up.


    How to change the cell to show the contact name instead of their email address

    Once you have clicked on their name and if an email shows up in the cell instead of their name, as shown below, you will need to do the following.

    Hover your mouse over the "Contact Name" column header and choose the 3 dots at the right of the "Contact Name". Then, choose "Edit Column Properties...". Then select "Text/Number" and click "OK"

    The cell will now look like this.

    Now modify the cell contents to look like the following:

    Now, hover over the "Contact Name" column header and click on the 3 dots and switch it back to "Contact List" and click "OK"

    The contact's name instead of the contact's email will be showing and your problem is solved.

    Hopefully this helps someone. You can share the sheet with this person with various permission levels and set up automation to email them based on certain criteria for updates, etc. That's a whole other topic.

  • DJB
    DJB ✭✭✭

    I feel the respondents aren't understanding the question. The steps shown are basic and already known. The issue is that the contact is already set up with a name and email address in "My Smartsheet Contacts", but when adding the contact as an option to the contact column, for some contacts only the email shows up. I have tried numerous approaches as Moraki describes, but to no avail. Some contacts stubbornly remain email addresses only. This on a new sheet, so no history in the columns to consider.

  • DJB
    DJB ✭✭✭

    @moraki, were you ever able to resolve your issue? In my case, what i found is that although i had set up the contact correctly, the contact's profile would override my setup. So if they hadn't set up their profile i would only get their email address. In our case, all the contacts are a part of a business plan - licensed and unlicensed.