Why won't my dashboard update automatically?

I have a dashboard that references one sheet. The dashboard will not update unless I make a change on the sheet it references. I've tried refreshing the dashboard several times, checked on my phone smartsheet app, different computers, its not updating anywhere. Once I make even a minor change on the sheet it references and I refresh the dashboard, only then does the dashboard update.

The specific columns I care about from the referenced sheet are columns that count how many days since another column was updated. For example, I have a "stage" column that is a dropdown list. The next column counts how many days since the stage column changed. In the dashboard, the column that counts how many days will not update unless I go make a change in the sheet.

Anyone know how to fix this?

Thanks in advance!

Tags:

Answers

  • Matt Johnson
    Matt Johnson ✭✭✭✭✭✭

    Hi @Beth M

    Do any of your formulas use the TODAY function? If so, the work around is to add a new date column and set up an automation to record today's date in that column everyday at like 1:00am. That refreshes the sheet. If data is updated on the sheet throughout the day, then the sheet gets refreshed when its saved. If no one touches the sheet throughout the day, worst case it will be refreshed at 1:00am.

    This work around might sound a little odd but I learned about it awhile back here on the forums. I've never heard of needing this if you don't have TODAY functions but I guess regardless this is one way to auto-refresh a sheet without going into it each day.

    I hope that helps.

    Matt

    Matt Johnson

    Sevan Technology

    Smartsheet PLATINUM Partner

  • Beth M
    Beth M ✭✭
    edited 07/18/23

    YES! It does use the TODAY function! When building my automation, what would the trigger be? Would it be 'when rows are added or changed', or would it be 'when a date is reached'? I just added a Helper Column and made it a date column. I created an automation and attached a screenshot. Does it look right?


    Thank you!!!

  • ajuelsgaard
    ajuelsgaard ✭✭
    edited 11/06/23

    I am experiencing the same issue. This seemed to have worked perfectly! Thanks!