@ Mention Function Not Working for Specific Employees

Hi all! First time poster, long time user of SmartSheets. I utilize SmartSheets within my company for requests and tracking purposes. Lately I've had multiple users who have been tagged in sheets on a line and are not receiving the push notification to email or the notification on their alerts in SmartSheets. I have verified the settings of all users and they are all set to receive email notifications in conjunction with all other notification methods.

Any advice on how to solve this problem?

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hey @RNelson88

    Any chance your organization uses a service to filter potential junk mail, such as Mimecast? See: Issue: Email not received from Smartsheet

    Another thing to check is if the users are shared to the sheet. Here's the documentation for @mentions.

    If none of this has helped, it would be useful to know what type of Smartsheet plan you're on and how you're @mentioning these users (e.g. from a sheet, within a Workapp or Dynamic View...)

    Cheers,

    Genevieve

  • rshelnutt
    rshelnutt ✭✭✭✭

    This is a very simple thought, but make sure the email addresses are correct in the contact list of whomever is tagging them. Just because it's right in one person's list, doesn't mean it's right in someone else's list. Our company has a pretty standardized approach to assigning emails, but now that we are over 3000 strong, we have multiple employees with the same first initial and last name. So, they sometimes use the first 2-3 letters of the person's name. If we're not careful, it's pretty easy to mistype the email address and then they don't get anything.

    Hope you get a resolution.

    Regina

  • We are on an Enterprise Plan. I get notifications and emails from SmartSheets daily, as well as several other users with no issue, so I don't believe it is an email filtering issue, especially considering the @ mention notification doesn't show up in their SmartSheet notification bar, either. I have verified the users settings and email are correct.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @RNelson88

    Thanks for following up!

    If you've double checked that the email and contact you're @mentioning directly in the sheet is the same as what the user is logging in with, but they're not seeing any in-app notifications or email notifications (even though their personal notification settings are correctly configured), then please provide all of this information and screen captures to the Support team using the Support Portal.

    They will be able to troubleshoot this with you in a private channel where you can provide details such as the contact email and images.

    Thanks,

    Genevieve