Contact Upload Feature No Longer Working

I am onboarding several people onto Smartsheet and have requested that they upload a list of contacts to populate their contact sheet. However, while they are able to upload the .csv file, nothing happens when they press continue.

I tested this myself and got the same result, which is odd as this was working fine around a week ago. I also tried saving as different .csv types with no success. Any help troubleshooting this would be greatly appreciated.

Also, for context, the .csv file is formatted exactly as stated in the guide (https://help.smartsheet.com/learning-track/get-started/contacts).

Best Answer

Answers

  • Genevieve P.
    Genevieve P. Employee Admin
    edited 08/18/23

    Hi @joedixon

    I experienced the same thing when formatting my CSV file the same way as in the Help Documentation.

    To test, I Exported my contacts and saw that in that CSV the headers are:

    1. Email Address
    2. Name

    In that order. I updated my file to import to only have those two fields and the import came through correctly. Please test and see if those headers work for you as well!

    Thanks,

    Genevieve

  • Hi Genevieve,

    Thank you for your help here. I have tested your proposed solution and am still getting the same result. I have a support ticket open to help further troubleshoot this but I am going to guess that something recently changed with the contacts functionality considering that section of the help article is no longer relevant.

    Any additional thoughts on fixing this would be greatly appreciated.

  • Genevieve P.
    Genevieve P. Employee Admin
    edited 08/16/23

    Hi @joedixon

    The Help Article does still list the current intended behaviour so what you're experiencing is unexpected; please keep following up with the Support ticket, thank you!

    In the meantime, the way I was able to update my own Contact List was by downloading my Contact List as a CSV, then using that same file to update the name/emails of who I wanted to import, importing the same file back in.

    Cheers,

    Genevieve

  • Fcon13
    Fcon13 ✭✭✭

    Still no solution to this?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Fcon13

    This is currently being investigated; have you tried importing your contacts with the different headers provided above?

  • Pasting information that I received for the support team:

    "I understand that when using the Import Contacts feature the contacts in the CSV file are not being added to your My Smartsheet Contacts list. Upon review, I am able to reproduce this behavior within my own user accounts.

    I have identified the error logs being generated by the import action and these indicate that our system is incorrectly identifying the email addresses in the CSV file as breaking email address formatting rules. A possible cause for this behavior is that Excel is incorrectly adding unnecessary characters, such as spaces after the email address, however, to investigate and confirm this, I have engaged our Engineering team and as soon as I have an update from them I will let you know.

    In the meantime, I have noticed that if I import the contact list into Google Sheets and then use the File>Download>Comma Separated Values option to return this to a CSV file. This downloaded CSV file appears to import as expected in the My Smartsheet Contacts window.

    If Google Sheets is available to you, may I ask that you try the steps above to determine whether we can mitigate the impact of the unexpected behavior?"

    I personally don't use Google Sheets buy may be worth a try if that is available to you.

  • Fcon13
    Fcon13 ✭✭✭

    I appreciate their response, but it still doesn't provide any clear instructions...much like Genevieve's response. "Try" different headers and importing to Google sheets does not say what the format or headers should be for this to work. It is a simple and critical function that makes Smartsheets impossible to use effectively without.


    Any specific steps would be appreciated

  • I am having the same issue and have tried all suggestions above. Would appreciate assistance with this issue.

  • I am experiencing this issue as well. It is crucial this is fixed ASAP. I have over 60 contacts I need to import. Is there an update?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi all,

    Here are two possible ways to bulk-upload contacts while the team is investigating a fix:

    1) If you're on a Mac, use a CSV with the headers:

    • Email Address
    • Name

    2) This has worked for other users if they don't a Mac but they do have access to Google Sheets:

    • Import the CSV into Google Sheets
    • Download the same file from Google sheets as a CSV
    • Use this new file in the Import Contacts process.


  • If Google Sheets isn't an option, opening the .csv in Notepad and saving before importing also works.

  • Genevieve P.
    Genevieve P. Employee Admin
    Answer ✓

    Hi all,

    (@joedixon @Fcon13 @Shelli G. @cjacobs210 @BaggLunch)

    We've implemented a fix and are testing the results, the bulk Contact upload feature should now be working with the correct headers of:

    First Name / Last Name / Email Address

    Please try formatting your CSV file as the Help Article states and let me know if it's working again for you now!

    Cheers,

    Genevieve

  • I'm experiencing the same issue and have tried both CSV formatting options mentioned above. There is no option available for Google Sheets, only CSV and VCF.