Using Smartsheet form to update existing sheet not working from some tablets

Hello,

I have implemented a form to facilitate updates to a spreadsheet. The form functions properly when accessed from PCs. However, there's an issue when attempting to update the sheet using a tablet, which our operations team uses on the shop floor. Strangely, when I used the same account on a phone, the form worked perfectly. (I am using the Smartsheet App on both the tablet & the phone)

Upon submitting the form, a green checkmark is displayed along with the message: "Submitted, success! We've captured your response." Despite this confirmation, I am perplexed as to why the submitted data isn't showing up in the spreadsheet.

I'm uncertain if the problem lies with the tablet itself, but I'm hoping to uncover some insights here.

Thank you.

Answers

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    Have you ensured you are using the most recent version of the app?

    Have you checked the activity log in the sheet to see if there is any indication what is happening?

  • Emad AJ
    Emad AJ ✭✭

    Hi Paul,

    Thank you for getting back to me

    the version is 11.4.260 (attached is a snapshot) which I

    think it is the latest

    Also I checked the the activity log, there is nothing indicates that the any form was submitted or sheet was accessed from the tablet.

    The problem is that the tablet is controlled by our IT and cannot access any browser on the tablet, I got them to check the firewall settings but all seems to be okay

    I know it is from the tablet, because I tried submitted through my phone from the same account and it worked. But I don't know how to work around it !

    Cheers,



  • rashichouhan
    rashichouhan ✭✭
    edited 08/28/23

    Hi,

    To troubleshoot and resolve this problem, you can try the following steps:

    Check Form Configuration:

    You must verify that the form configuration is consistent across all devices. Please make sure that the form questions, options, and settings are the same on both the PC and tablet (It's important).

    Double-check that the form submissions are being sent to the correct destination sheet in Smartsheet.

    Network and Connectivity:

    This is most common, confirm that the tablet has a stable and active internet connection. Inconsistent connectivity might result in form submissions not being successfully transmitted to the server.

    If the tablet is connected to a Wi-Fi network, try switching to a different network to see if the issue persists.

    I hope this will help.

    Thanks

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    If the tablet cannot access a browser, how are you able to access the form? Is it available offline?

  • Emad AJ
    Emad AJ ✭✭

    we are accessing the forms through the Smartsheet application and it is not offline as the tablet is connected to a 4G network

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    If I am not mistaken, I believe forms don't open in the app. I thought they opened in a browser or offline. Exactly how are you accessing the form? Do you go into the app and click on a link? Is it a link in a dashboard? Something else entirely?


    @Genevieve P. What am I missing?

  • Genevieve P.
    Genevieve P. Employee Admin
    edited 08/29/23

    Thanks for the tag, @Paul Newcome!

    Forms can open in the Smartsheet App or in a Browser App, depending on what the user has on their phone. In the Smartsheet App, you can pin Forms as favourites to easily access them. You can also submit forms while being offline. (Here's more information: Differences between the web and mobile app)

    Is there any possibility that the Form being accessed on the Tablet is actually a test form or a different one associated with a separate sheet?

    @Emad AJ, can you test by navigating directly to the sheet in the tablet and finding the Form from the sheet, then submitting from there? (Versus using search or recents)

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭
    edited 08/29/23

    @Emad AJ What she said... ^^


    @Genevieve P. Thanks! I didn't realize you could favorite forms in the app. I opened the form on my phone both from the app and in a browser tab, and they both looked the same (only options I had in the app were to make it available offline or to share).


    My next step was going to be to confirm that we were in fact navigating to the correct form or not accidentally looking at the wrong sheet for the form entries. That's why I asked exactly what steps were being taken to open the form. Making sure links were correct and whatnot.

  • Genevieve P.
    Genevieve P. Employee Admin

    Ah, my apologies! 🤦‍♀️ Typing too fast this afternoon...I've edited my post - you cannot "favourite" Forms in the app, but they appear in the Recents on the Home screen for easy-access.

  • Emad AJ
    Emad AJ ✭✭

    Hi Gen / Paul,

    Users are currently accessing the form through a hyperlink sent via email. Upon clicking the link, the form opens automatically within the Smartsheet APP. To assess the situation, I attempted the same process using my mobile device. I clicked the link within the email, successfully submitted the form, and observed that the corresponding sheet was promptly updated. This outcome confirmed the proper functionality of the process on mobile devices.

    However, the challenge emerges when attempting the same procedure on a tablet. After clicking the link, the form opens seamlessly, allowing me to make necessary updates. Upon submission, a green checkmark appears, confirming the successful form submission. Strangely, despite this confirmation, the data fails to transfer to the designated sheet.

    The tablet maintains a stable internet connection. This is evident from its ability to send and receive emails, as well as its smooth operation with other work-related applications.

    Our IT team is investigating potential firewall settings that might be influencing this issue. Despite their efforts, I'm still unable to discern the underlying cause. The situation remains perplexing: the form submission process appears to be successful, yet the actual data transmission to the sheet is not occurring.

    As suggested we accessed the form directly from the actual sheet, yielding the same outcome as described above.

    Recently, I made a noteworthy observation that may or may not be pertinent. The message I receive after submitting the form from either a mobile device or a PC matches the verbiage present in the form settings: "Success! We've captured your response." However, when submitting from a mobile device, the message differs: "Thank you. Your response has been added to my Smartsheet." - check attached

    Thank you for your attention and support.

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    It almost sounds as if you are using a different form.


    Did you forward the email containing the link that worked from the mobile device to the tablet just to be sure you are in fact using the correct hyperlink?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hey @Emad AJ

    I agree that this sounds strange, and the most likely scenario is that these are two different forms with the same name. I say this because the Success message is slightly different and because your Activity Log is not showing any row submissions.

    You are on the most up-to-date version of the app and the Success screen means that the row should be appearing in your sheet. Just in case, can you test the following:

    • Can you apply a Filter to the sheet on a column that always has data in case the rows are appearing in an unexpected place? (E.g. at the very bottom of the sheet with blank rows between)
    • Check to see if there are any workflows that are moving rows right after they're submitted
    • Can you check the Form Submissions on the sheet to see if it lines up with the submissions coming through your Tablet or not:


    See how this says 0 Submissions:






    If none of this has helped and you can confirm that the URL for the form is the exact same, please do reach out to Support with the following details:

    • Sheet URL and Name
    • Form URL
    • All of the screen captures from this Community thread
    • All of the testing you've done from this thread


    Thank you!

    Genevieve

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    @Genevieve P. Checking the form submission counter is a great idea. Check the number from the mobile device, submit on the tablet, see if the number on the mobile device changes. If it doesn't then we are definitely using the wrong form. If it does, but there is no evidence of a submission otherwise... Well then we have other problems.

  • Emad AJ
    Emad AJ ✭✭

    I reviewed the submission counter and noticed that it wasn't incrementing. This issue wasn't specific to just one form; it affected all other forms as well.

    Luckily, our IT department was able to resolve the problem, which turned out to be related to firewall settings.

    However, what's perplexing is that I'm still receiving different messages upon completing a submission, and these messages don't align with the information provided in the form. While this isn't a major concern, it's certainly unusual.

    In any case, I want to express my gratitude for the assistance and time you all dedicated to resolving this matter. Thanks to your efforts, everything is up and running for the time being.

    Wishing you all a wonderful weekend!

    Cheers,