Form Date Format defaults to MM/DD/YYYY even though Form is set to DD/MM/YYYY

Options

Hi all

I searched the topics and other questions but could not find a satisfactory answer.

I am in the UK and have set my setting to DD/MM/YYYY but I'm using a US licence (global company)

On the sheet, a date column is formatted to DD/MM/YYYY - when I open the form from the link, the date is DD/MM/YYYY


but I can't change the input on the form to DD/MM/YYYY and if a Client or colleague (who does not have a licence) completes the form, the Format is MM/DD/YYYY.

And when the automation email triggered by the form being complete comes through the date is in MM/DD/YYYY even though when I look at the sheet its in DD/MM/YYYY

How can I change the default format on the form?

Help!

Answers

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hey @Lisa Bagshaw

    You're correct, the Form Builder shows MM/DD/YYYY when you select a default value but that is just within the builder.

    If your Form permission settings are configured so that the user needs to Sign In to Smartsheet to fill out the form, they should see the date format that they have set up in their Personal Settings. This is why when you open the form you'll see DD/MM/YYYY, but someone with US settings should see MM/DD/YYYY.

    Automations should also display the data based on your Account's Personal Settings. Is the screen capture above, is that from someone else's account? Is it possible they have their Account set as US date format?

    Keep in mind the Formatting applied directly in the Sheet for that specific column is different than an Account setting.

    Let me know if this helps!

    Cheers,

    Genevieve